[svlug] Reiserfs 2

Smitty 76543a at mpinet.net
Thu Mar 22 17:55:02 PST 2001


It looks to me that the problem here is the "patched" 2.2.1x kernel in
RedHat.  The 2.4.x kernel supports arbitrary file systems; ext3, Xfs,
Reiserfs, und so weiter.  I know the SuSE patched 2.2.1x kernel works
with the SuSE application tree in Reiserfs, but would not necessarily
work with the RedHat application tree.  Why can't you simply use the
latest 2.4.x kernel?
Regards,
Smitty

Todd Lyons wrote:
> 
> I have successfully gotten RH 6.2 to boot with Reiserfs as / and an ext2
> partition as /boot.  I have 2 small problems, but I want first want to
> explain what all I did in case you see a problem there.
> 
> 1) As pointed out, I used the reiserfs tools in the patched kernel to
> make a reiser file system on /dev/hda3.  To install the tools, I did:
>    cd /usr/src/linux/fs/reiserfs/tools
>    make
>    make install
> 2) mkreiserfs /dev/hda3
>    mount -t reiserfs /dev/hda3 /usr2
> 3) cp -a /bin /etc /home /lib /mnt /root /sbin /tmp /usr /var /usr2
> 4) cd /mnt/cdrom
>    rpm -ivvh --root /usr2 dev86* dev-* #installs /dev/ entries
> 5) Repeat rpm without the --root /usr2 to bring rpm database back to
> current.
> 6) cd /usr2/sbin
>    ln -s reiserfsck fsck.reiserfs
> 7) cd /usr2/etc
>    vi fstab   # and modify entry for / partition
> 8) cd /usr2/etc/rc.d
>    vi rc.sysinit   # and change fsck of / to not use initlog
>                    # also added -v for verbose
> 9) mkdir /usr2/proc   # creating mountpoints
>    mkdir /usr2/boot
> 10)cd /etc
>    vi lilo.conf   # and add an entry to use new reiser as root
>    lilo           # to save to MBR
> 
> Reboot and it worked.
> 
> Now for the two problems
> A) On bootup, at first it asked me if I'm sure I want to run
> reiserfsck.  I had to manually type yes.
> B) Every subsequent bootup, it failed with "/dev/hda3 contains a mounted
> partition" and drops me into repair mode.
> 
> so I then did:
> 11)touch /fastboot
> 
> In the RedHat rc.sysinit, it looks for a /fastboot.  If it finds it, it
> skips all of the root fs check and just goes straight to the mount -o
> remount,rw /.  I am doing this currently.
> 
> Since this is a journaling file system, what problems are going to pop
> up from doing this?  I have tried a couple things (shutting down while
> in X, shutting down while startx && ldconfig happening at same time) and
> it seemed to handle it gracefully.
> 
> I want to figure out how to get reiserfsck to check a reiser partition
> mounted read-only.  If the answer is "not possible" then I go with the
> /fastboot option to bypass root checking.  If the answer is "that's the
> whole point of journaling, it essentially does an fsck while it's
> mounting" then my question is already answered.
> 
> On this system, I can still boot to my regular ext2 root partition to
> repair anything on the reiserfs, but on the system I plan to install
> this on (mobile car mp3 player), I plan to blow away the ext2 partition
> after I create the root on reiser.  And this won't have a cd player to
> boot with the reiser bbc to repair it.  So I can't commit to something
> that will die every 20th time the power is dropped.  This system won't
> be doing much except for running apache as a frontend for a bunch of
> perl scripts and spawning mpg123 to play mp3s.  I plan to add wireless
> networking and ssh to allow me to send new mp3s to the system without
> having to bring the box inside, but we'll see if that works out the way
> I want.
> 
> The other answer that I haven't mentioned is leaving / as ext2, make it
> ro, and break off /var and /tmp and make them reiser.  What do you think
> about that approach?  I recall an issue with /etc/mtab needed to be rw,
> but I don't remember the specifics.
> 
> All comments appreciated.
> --
> Blue skies...           Todd
> | Get a bigger hammer!   |  Two things prevent you from having    |
> | http://www.mrball.net  |  sex with women:  sunlight & sobriety  |
> | http://faq.mrball.net  |                          --Tom Leykis  |
>




More information about the svlug mailing list