[svlug] Hopefully the last ethernet problem

Brandon Arnold billygotee at operamail.com
Wed Mar 21 17:35:01 PST 2001


I finally had my Kingston KNE30BT(realtek 8029 driver, ne2k-pci) running
fine.  When I formatted, I figured I would only have to reinstall the
driver, as my BIOS would still have Plug-n-Play turned off after I installed
Mandrake again.  It doesn't work anymore, however.  Mandrake detected the
card the first time I booted up, and I actually had a ping.  It never would
surf the net though.  I dont know what I changed (if anything), but it
doesn't even load on startup now.  Even so, I can't reinstall the ne2k-pci.o
because its already in use.  Linux doesn't detect the card at IRQ 9, even
though I have the line ether=9,0x340,eth0 in my GRUB file, so I'm not sure
what to do next.  These are the knowns:

-When I log onto Linux, all other computers on the network lose their
connection-this one's kinda weird.

-It seems like it stopped working when I removed my other ethernet card--I
had two ethernet cards in two different PCI slots on different IRQ's...this
reminds me I might oughta take the line out of my grub menu to see what
happens...that's a negative it still does the same thing.

-no eth0 after ifconfig.  Here's some reponses I got in a terminal that'll
help.  I'm not sure what the cdrom failure is all about, but it works fine.

# dmesg | tail

lp0: using parport0 (polling).
cdrom: open failed.
VFS: Disk change detected on device ide1(22,0)
VFS: Disk change detected on device ide1(22,64)
ide-scsi: hdd: unsupported command in request with queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 64
isofs_read_super: bread failed, dev=16:40, iso_blknum=16, block=32
VFS: Disk change detected on device fd(2,0)
end_request: I/O error, dev 02:00 (floppy), sector 0
VFS: Disk change detected on device fd(2,0)

# modprobe ne2k-pci

/lib/modules/2.2.17-21mdk/net/ne2k-pci.o: invalid parameter parm_io
/lib/modules/2.2.17-21mdk/net/ne2k-pci.o: insmod
/lib/modules/2.2.17-21mdk/net/ne2k-pci.o failed
/lib/modules/2.2.17-21mdk/net/ne2k-pci.o: insmod ne2k-pci failed

# make    <--after I untarred the netdrivers.tgz

make: *** No rule to make target '/usr/src/linux/drivers/net/8390.h',needed
by
'ne2k-pci.o'. Stop.

-Brandon





More information about the svlug mailing list