[svlug] Sharing LNE100TX blues...

Erik Steffl steffl at bigfoot.com
Mon Mar 19 01:25:01 PST 2001


  I don't think that card works in all situations, not sure what's the
problem, it looks like Donald Becker does not have all the needed info,
specially on the media selection (I am not sure about this, but they
definitely do not have enough info).

  almost everybody was able to make the card work somehow, for example
my card was sort of working but was either freezeing (nothing would be
transmitted until the driver is reload) or connections were broken
(while other connections worked). I tried various version of driver,
patches from tulip mailing list etc... nothing helped...

  that's my experience...

	erik

> Brandon Arnold wrote:
> 
> I've been battling with my LNE100TX v4 NIC for the past 3 days.  I see
> its a common problem with most Linux folks that have bought it, but
> since I've read lots of posts claiming success, I have faith that I'm
> doing something wrong.
> 
> For all obvious reasons, the NIC isn't there.  Be aware, it works fine
> when I boot into Windows ME, so the card is plugged in securely.  I
> tried to use the netdrivers.tgz that was included on the installation
> disk for Linux users.  The files unzipped correctly, but only a few
> compiled.  I wont go into extensive detail about that, because most
> posts suggested compiling the updated tulip.c driver at Becker's
> site.  Therefore, I downloaded the latest tulip.c, pci-scan.c,
> pci-scan.h, and kern_compat.h, ran DOS2UNIX on them and then placed
> them all in the /usr/src/modules directory.  The compile command gave
> me fits because it is different for Mandrake 7.2, but I finally came
> up with the following:
> 
> For tulip.c:
> 
> # gcc -I/usr/src/linux-2.2.17/include -DMODULE -Wall
> -Wstrict-prototypes -O6 -c /usr/src/modules/tulip.c
> 
> For pci-scan.c:
> 
> # gcc -I/usr/src/linux-2.2.17/include -DMODULE -D__KERNEL__
> -DEXPORT_SYMTAB -Wall -Wstrict-prototypes -O6 -c
> /usr/src/modules/pci-scan.c
> 
> They both returned the compiled tulip.o and pci-scan.o files, but both
> times I received an assembling error in modprob.c.  I'm not sure if
> this matters--it seems like it would. :-)  Anyway I ran insmod on both
> of the compiled files.  pci-scan.o installed correctly, but when I
> tried to install tulip.o, it returned 'tulip is busy' or something to
> that effect.  It seems like I read a few posts where people fixed this
> problem by changing the slot that the card was in.  Anyway, I changed
> the card to the slot directly below it, but still no cigar.  Of
> course, Windows ME still works.  Please forgive me on the
> non-descriptiveness of the errors, I had to reboot into Windows ME to
> type this message and forgot to record the exact statement. I think I
> included enough information for a guru to cite my problem, but if you
> need the exact statements, by all means, post and I'll include those
> as well.  I guess what I want is first hand instructions from someone
> else who had the same problem in Linux Mandrake 7.x and got it fixed,
> but I also welcome help from anyone else who sees my mistake. Thanks
> in advance!
> 
> -Brandon Arnold




More information about the svlug mailing list