[volunteers] www.svlug.org NSD and distro upgrade notes

Daniel Gimpelevich daniel at gimpelevich.san-francisco.ca.us
Mon May 2 03:20:21 PDT 2016


On Mon, 2016-05-02 at 01:29 -0700, Rick Moen wrote:
> This system runs _old_ Ubuntu Server release 12.04.2 LTS, and is in
> need of update.
> 
> Currently available LTS (long-term support release) is 14.04.1 LTS
> (Trusty Tahr).  I believe said upgrade replaces the Upstart init with
> the systemd one.

Precise Pangolin (12.04) will continue to receive updates until next
April, but this July, it will become possible to upgrade from Trusty
Tahr (14.04) to Xenial Xerus (16.04), so I would recommend keeping 12.04
until that time. Trusty does package systemd, but not as PID 1. Xenial
has it as PID 1.

> Notice the recommendation about making sure your VM is using the latest
> supported kernel.

The VM is currently running a 4.1.5 kernel. Trusty uses a 3.13 kernel,
and Xenial uses a 4.4 kernel. The nsd package is 4.0.1 in Trusty, and
4.1.7 in Xenial.





More information about the volunteers mailing list