<div dir="ltr">I am wondering if because your new root partition is LVM that is causing an issue since it&#39;s not just a simple device file with a simple filesystem. Perhaps booting with rdinit=/bin/sh and seeing if you can mount the F22 RFS may be a clue.</div><div class="gmail_extra"><br><div class="gmail_quote">On Tue, Nov 3, 2015 at 2:34 PM, Sarah Newman <span dir="ltr">&lt;<a href="mailto:newmans@sonic.net" target="_blank">newmans@sonic.net</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">The kernel and initramfs for fedora 22 should be located where fedora 22 is going to update them, not manually copied. If you must have separate /boot<br>
partitions, maybe try chain-loading the config file with the configfile directive. You may have to manually fix the &quot;set root=&quot; directive.<br>
<br>
Have you tried booting by label or partition instead of UUID?<br>
<span class="im HOEnZb"><br>
On 11/03/2015 01:47 PM, Michael Eager wrote:<br>
&gt; I installed a new SSD in my workstation and installed<br>
&gt; Fedora 22 on the new drive from a Fedora Live DVD.  The new<br>
&gt; SSD has a separate /boot partition and the root partition is in an LVM.<br>
&gt;<br>
&gt; When I reboot, the workstation boots back to the old Fedora 18<br>
&gt; system, with no menu entry for the new F22 system.  I ran<br>
&gt; grub2-install and it updated grub2.cfg with the F22 install,<br>
&gt; using os-prober.  I did have to update device.map to include<br>
&gt; both the boot drive (hd0,/dev/sda) and the new SSD (hd2,/dev/sdc).<br>
&gt; I also copied the initrd and vmlinux from the new SSD /boot<br>
&gt; partition to the original /boot partition.<br>
&gt;<br>
&gt; When I try to boot F22, it mounts a partition from a different<br>
&gt; LVM on a different disk (/dev/sdb) as /sysroot and then dies<br>
&gt; in switch-root because it doesn&#39;t contain root file system.<br>
&gt; I&#39;ve checked the UUIDs in grub2.cfg and they all seem correct.<br>
&gt;<br>
&gt; I also tried to create a chainloader, but that fails complaining<br>
&gt; about an invalid checksum.<br>
&gt;<br>
&gt; Does anyone have an idea what is going on or how to get<br>
&gt; grub2 configured correctly?  Or how to install a second Linux<br>
&gt; distro in a way which works?<br>
&gt;<br>
<br>
<br>
</span><div class="HOEnZb"><div class="h5">_______________________________________________<br>
svlug mailing list<br>
<a href="mailto:svlug@lists.svlug.org">svlug@lists.svlug.org</a><br>
<a href="http://lists.svlug.org/lists/listinfo/svlug" rel="noreferrer" target="_blank">http://lists.svlug.org/lists/listinfo/svlug</a><br>
</div></div></blockquote></div><br><br clear="all"><div><br></div>-- <br><div class="gmail_signature">visit <a href="http://www.kcomputing.com" target="_blank">www.kcomputing.com</a> for the best in Linux developer training.</div>
</div>