<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">
<META NAME="Generator" CONTENT="MS Exchange Server version 5.5.2650.12">
<TITLE>RE: [svlug] Network cards supporting Linux</TITLE>
</HEAD>
<BODY>

<P><FONT SIZE=2>I had trouble getting my 3Com Megahertz 10/100 to work until I changed when PCMCIA initialized so it initialized before networking.&nbsp; I changed it from S45PCMCIA in rc3.d &amp; rc5.d to S04PCMCIA (I am going from memory...Don't have a Linux box at work yet)&nbsp; Now I can interchange my 3Com 10MB &amp; my 3Com 10/100 cards at will.&nbsp; Gave up trying to get my 10/100/56k Modem card to work.&nbsp; Haven't tried it since the change though.</FONT></P>

<P><FONT SIZE=2>-PaulK</FONT>
</P>

<P><FONT SIZE=2>*********************************************</FONT>
<BR><FONT SIZE=2>Paul Keser</FONT>
<BR><FONT SIZE=2>Network Security Engineer</FONT>
<BR><FONT SIZE=2>paulk@shopexpert.com</FONT>
<BR><FONT SIZE=2>tel:&nbsp;&nbsp; 415.351.4037</FONT>
<BR><FONT SIZE=2>fax:&nbsp; 415.474.6017</FONT>
</P>

<P><FONT SIZE=2>ShopExpert.com</FONT>
<BR><FONT SIZE=2>1375 Sutter Street, Suite 400</FONT>
<BR><FONT SIZE=2>San Francisco, CA&nbsp; 94109</FONT>
<BR><FONT SIZE=2>*********************************************</FONT>
</P>
<BR>

<P><FONT SIZE=2>&gt; -----Original Message-----</FONT>
<BR><FONT SIZE=2>&gt; From: Todd A. Lyons [<A HREF="mailto:todd@mrball.net">mailto:todd@mrball.net</A>]</FONT>
<BR><FONT SIZE=2>&gt; Sent: Tuesday, May 23, 2000 6:56 AM</FONT>
<BR><FONT SIZE=2>&gt; To: World Domination</FONT>
<BR><FONT SIZE=2>&gt; Subject: [svlug] Network cards supporting Linux</FONT>
<BR><FONT SIZE=2>&gt; </FONT>
<BR><FONT SIZE=2>&gt; </FONT>
<BR><FONT SIZE=2>&gt; Bill Jonas wrote:</FONT>
<BR><FONT SIZE=2>&gt; </FONT>
<BR><FONT SIZE=2>&gt; &gt; I don't know about tech support, but NetGear says right on the box</FONT>
<BR><FONT SIZE=2>&gt; &gt; (FA310TX) that their card works with Linux.</FONT>
<BR><FONT SIZE=2>&gt; </FONT>
<BR><FONT SIZE=2>&gt; We had an ordeal this weekend with an ambicomm pcmcia network </FONT>
<BR><FONT SIZE=2>&gt; card (AMBI8110)</FONT>
<BR><FONT SIZE=2>&gt; that we tried to get working in a Toshiba Satellite 460.&nbsp; </FONT>
<BR><FONT SIZE=2>&gt; They provided a</FONT>
<BR><FONT SIZE=2>&gt; module (amb8110.o), plus the source to the module and an </FONT>
<BR><FONT SIZE=2>&gt; altered pcnet_cs.c. </FONT>
<BR><FONT SIZE=2>&gt; We tried copying the precompiled module into into the </FONT>
<BR><FONT SIZE=2>&gt; appropriate modules</FONT>
<BR><FONT SIZE=2>&gt; directory, however, depmod complained of unresolved symbols.&nbsp; </FONT>
<BR><FONT SIZE=2>&gt; So we did the</FONT>
<BR><FONT SIZE=2>&gt; alternate steps of extracting the sources and recompiling and </FONT>
<BR><FONT SIZE=2>&gt; installing</FONT>
<BR><FONT SIZE=2>&gt; modules.&nbsp; It all worked fine and the module loaded fine including all</FONT>
<BR><FONT SIZE=2>&gt; dependencies.&nbsp; But the ethernet would not initialize (this </FONT>
<BR><FONT SIZE=2>&gt; was on a RedHat</FONT>
<BR><FONT SIZE=2>&gt; system).&nbsp; Install my D-Link 660 and it initialized with no problem.</FONT>
<BR><FONT SIZE=2>&gt; </FONT>
<BR><FONT SIZE=2>&gt; Another laptop had similar results with a 3Com MegaHertz </FONT>
<BR><FONT SIZE=2>&gt; Cardbus Ethernet</FONT>
<BR><FONT SIZE=2>&gt; card.&nbsp; I know that pcmcia on Linux is supposed to do Cardbus </FONT>
<BR><FONT SIZE=2>&gt; (right?) but we</FONT>
<BR><FONT SIZE=2>&gt; ran out of time and beer to work on it.&nbsp; Again, plug mine in </FONT>
<BR><FONT SIZE=2>&gt; and it worked</FONT>
<BR><FONT SIZE=2>&gt; with no problems.</FONT>
<BR><FONT SIZE=2>&gt; </FONT>
<BR><FONT SIZE=2>&gt; In short, both those people planned on getting different </FONT>
<BR><FONT SIZE=2>&gt; pcmcia network cards,</FONT>
<BR><FONT SIZE=2>&gt; but it seems as if those two _should_ have worked.&nbsp; I would </FONT>
<BR><FONT SIZE=2>&gt; have liked more</FONT>
<BR><FONT SIZE=2>&gt; time to work on them, but like I said, we ran out of beer and </FONT>
<BR><FONT SIZE=2>&gt; time.&nbsp; Any</FONT>
<BR><FONT SIZE=2>&gt; recommendations on 10/100 cards?</FONT>
<BR><FONT SIZE=2>&gt; -- </FONT>
<BR><FONT SIZE=2>&gt; Blue skies... &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Cannonball&nbsp; &nbsp;&nbsp;&nbsp; <A HREF="http://www.mrball.net" TARGET="_blank">http://www.mrball.net</A></FONT>
<BR><FONT SIZE=2>&gt; *&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; One GUI to rule them all, One GUI to find them&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; * </FONT>
<BR><FONT SIZE=2>&gt; *One GUI to bring them all, and with the blue screen bind them*</FONT>
<BR><FONT SIZE=2>&gt; *&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; In the land of Redmond, where the shadows lie.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; *</FONT>
<BR><FONT SIZE=2>&gt; </FONT>
<BR><FONT SIZE=2>&gt; </FONT>
<BR><FONT SIZE=2>&gt; _______________________________________________</FONT>
<BR><FONT SIZE=2>&gt; svlug mailing list</FONT>
<BR><FONT SIZE=2>&gt; svlug@lists.svlug.org</FONT>
<BR><FONT SIZE=2>&gt; <A HREF="http://lists.svlug.org/mailman/listinfo/svlug" TARGET="_blank">http://lists.svlug.org/mailman/listinfo/svlug</A></FONT>
<BR><FONT SIZE=2>&gt; </FONT>
</P>

</BODY>
</HTML>