[svlug] smartctl : strange behavior

kevin dankwardt kevin.dankwardt at gmail.com
Sat Oct 17 09:03:36 PDT 2015


Perhaps this will help. Of course it may not be /dev/sdb.

sudo smartctl -d sat --all /dev/sdb
sudo smartctl -d sat,12 --all /dev/sdb


from http://askubuntu.com/questions/637450/cannot-perform-smart-data-and-self-test-on-external-hard-drive




On Fri, Oct 16, 2015 at 11:49 PM, Lister <lister90 at bluehatsoft.com> wrote:

> All,
> I have a Seagate expansion desktop drive. I use Debian 8.1 on my
> desktop. In order to make the drive standby, I use smartctl.
>
> [2011]$ lsb_release -a
> No LSB modules are available.
> Distributor ID: Debian
> Description:    Debian GNU/Linux 8.2 (jessie)
> Release:        8.2
> Codename:       jessie
>
> [2006]$ lsusb  | grep Seagate
> Bus 002 Device 004: ID 0bc2:3320 Seagate RSS LLC SRD00F2 [Expansion
> Desktop Drive]
>
> [2010]$ sudo smartctl -s standby,now /dev/sde
> smartctl 6.4 2014-10-07 r4002 [x86_64-linux-3.16.0-4-amd64] (local build)
> Copyright (C) 2002-14, Bruce Allen, Christian Franke,
> www.smartmontools.org
>
> Device placed in STANDBY mode
>
> Just to be sure about the smart drive database,
>
> [2014]$ sudo update-smart-drivedb
> /var/lib/smartmontools/drivedb/drivedb.h is already up to date
>
> All good. No complaints here :-)
>
> Now, I connect this drive to my desktop running ubuntu 15.04
> [275]$ lsb_release -a
> No LSB modules are available.
> Distributor ID: Ubuntu
> Description:    Ubuntu 15.04
> Release:        15.04
> Codename:       vivid
>
> [278]$ lsusb  | grep -i seagate
> Bus 002 Device 004: ID 0bc2:3320 Seagate RSS LLC SRD00F2 [Expansion
> Desktop Drive]
>
> [279]$ sudo smartctl -a
> /dev/disk/by-id/usb-Seagate_Expansion_Desk_2HC015KJ-0\:0
> smartctl 6.4 2014-10-07 r4002 [x86_64-linux-3.19.0-30-generic] (local
> build)
> Copyright (C) 2002-14, Bruce Allen, Christian Franke,
> www.smartmontools.org
>
> Read Device Identity failed: scsi error unsupported field in scsi command
>
> A mandatory SMART command failed: exiting. To continue, add one or more
> '-T permissive' options.
>
> [280]$ sudo update-smart-drivedb
> /var/lib/smartmontools/drivedb/drivedb.h is already up to date
>
> [287]$ dpkg -s  libatasmart4 | grep Ver
> Version: 0.19-3
>
> Please note that the version of both smart4 library (0.19-3)as well as
> smartmontools (6.4) are same in both ubuntu and debian8.1. On both
> machines, the smartctl data base is upto date.
>
> How can the same verision binary (and library) produce such inconsistent
> output is beyond my comprehension. I even tried re-booting a couple of
> times. Any ideas? How can I proceed on ubuntu?
>
> Thanks,
> Om.
>
> _______________________________________________
> svlug mailing list
> svlug at lists.svlug.org
> http://lists.svlug.org/lists/listinfo/svlug
>



-- 
visit www.kcomputing.com for the best in Linux developer training.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.svlug.org/archives/svlug/attachments/20151017/0c970509/attachment-0001.htm


More information about the svlug mailing list