[svlug] Grub2 dual boot Linux

Sarah Newman newmans at sonic.net
Tue Nov 3 14:34:59 PST 2015


The kernel and initramfs for fedora 22 should be located where fedora 22 is going to update them, not manually copied. If you must have separate /boot
partitions, maybe try chain-loading the config file with the configfile directive. You may have to manually fix the "set root=" directive.

Have you tried booting by label or partition instead of UUID?

On 11/03/2015 01:47 PM, Michael Eager wrote:
> I installed a new SSD in my workstation and installed
> Fedora 22 on the new drive from a Fedora Live DVD.  The new
> SSD has a separate /boot partition and the root partition is in an LVM.
> 
> When I reboot, the workstation boots back to the old Fedora 18
> system, with no menu entry for the new F22 system.  I ran
> grub2-install and it updated grub2.cfg with the F22 install,
> using os-prober.  I did have to update device.map to include
> both the boot drive (hd0,/dev/sda) and the new SSD (hd2,/dev/sdc).
> I also copied the initrd and vmlinux from the new SSD /boot
> partition to the original /boot partition.
> 
> When I try to boot F22, it mounts a partition from a different
> LVM on a different disk (/dev/sdb) as /sysroot and then dies
> in switch-root because it doesn't contain root file system.
> I've checked the UUIDs in grub2.cfg and they all seem correct.
> 
> I also tried to create a chainloader, but that fails complaining
> about an invalid checksum.
> 
> Does anyone have an idea what is going on or how to get
> grub2 configured correctly?  Or how to install a second Linux
> distro in a way which works?
> 




More information about the svlug mailing list