[svlug] Can't get LFS systemd system to boot...

Scott DuBois rhcom.linux at gmail.com
Fri Jan 30 12:16:59 PST 2015


On Fri, Jan 30, 2015 at 12:23:32AM -0800, Michael Robinson wrote:
> >   VFS: Unable to mount root fs on unknown-block(0,0)
> 
> Yes, that was it.  Trouble is, how do I cut and paste the diagnostic
> message when the system isn't booting?
> 
> Here is my current grub.cfg:
> 
> [root at eagle64 ~]# ./enter_chroot.bash 
> root [ / ]# cd /boot/
> root [ /boot ]# ls
> config-3.16.2  lost+found         vmlinuz-3.16.2-lfs-7.6-systemd
> grub           System.map-3.16.2
> root [ /boot ]# cat grub/grub.cfg 
> # Begin /boot/grub/grub.cfg
> set default=0
> set timeout=5
> 
> insmod ext2
> set root=(hd0,msdos1)
> 
> menuentry "GNU/Linux, Linux-3.16.2-lfs-7.6-systemd" {
> 	linux /vmlinuz-3.16.2-lfs-7.6-systemd root=0x823 ro
> }
> root [ /boot ]# 
> 
> But now I get unknown-block(8,35).  Hmm, is it possible that I am
> not supporting the local SATA controller???  I believe that ext4 
> support is compiled in.   My motherboard is an MSI 785GM-P45.
> 
> Not sure about the unknown part of the message.  Maybe the drives
> remapped so that the root isn't 8,35 anymore.  Uge!

Not sure if this applies or not but thought I would throw it out there anyway:

http://kernelnewbies.org/KernelDebug

-- 
EFF ID: 1731778

"The difference between stupidity and genius is that genius has limits."
-- Einstein
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 490 bytes
Desc: Digital signature
Url : http://lists.svlug.org/archives/svlug/attachments/20150130/ff0968cc/attachment.bin


More information about the svlug mailing list