[svlug] Debian upgrade (was Debian Upgrade 7.8)

Scott DuBois rhcom.linux at gmail.com
Mon Jan 19 09:33:42 PST 2015


On Mon, Jan 19, 2015 at 02:13:03AM -0800, Rick Moen wrote:
> Scott DuBois wrote:
> 
> > Ah, but the problem with using the 'purge' switch is that it populates
> > 'autoremove' which throws warnings and doesn't seem to have a really
> > functional algorithm.
> 
> I really have no idea what that sentence means.  You might want to try again
> in English (or Francais, or Norsk - pick any n).
> 
> Probably a copy-and-paste would be useful.  

The following list contains packages I _know_ I want to keep.

roguehorse at linux:~$ sudo apt-get remove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  fetchyahoo libconvert-binhex-perl liblensfun-data liblensfun0
libmime-tools-perl libterm-readkey-perl ufraw-batch
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

If I run 'autoremove' it's going to get rid of them but some I want to keep. So
to clean up this list, I 'cherry pick' items out I _know_ I want to keep and add
them to an 'apt-get install' list.

roguehorse at linux:~$ sudo apt-get install fetchyahoo libconvert-binhex-perl
liblensfun-data liblensfun0 libmime-tools-perl libterm-readkey-perl ufraw-batch
Reading package lists... Done
Building dependency tree       
Reading state information... Done
fetchyahoo is already the newest version.
fetchyahoo set to manually installed.
liblensfun-data is already the newest version.
liblensfun-data set to manually installed.
liblensfun0 is already the newest version.
liblensfun0 set to manually installed.
libconvert-binhex-perl is already the newest version.
libconvert-binhex-perl set to manually installed.
libmime-tools-perl is already the newest version.
libmime-tools-perl set to manually installed.
libterm-readkey-perl is already the newest version.
libterm-readkey-perl set to manually installed.
ufraw-batch is already the newest version.
ufraw-batch set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
roguehorse at linux:~$ sudo apt-get remove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Thus, cleaning out the list.

-- 
EFF ID: 1731778

"The difference between stupidity and genius is that genius has limits."
-- Einstein
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 490 bytes
Desc: Digital signature
Url : http://lists.svlug.org/archives/svlug/attachments/20150119/9cc050cf/attachment.bin


More information about the svlug mailing list