[svlug] SSD failure???

Marco Walther marco at sonic.net
Sat Apr 12 10:37:24 PDT 2014


On 04/12/2014 09:25 AM, Michael Robinson wrote:
> Transcript of session follows.
>
>   Out: 220 xerxes.robinson-west.com ESMTP Postfix
>   In:  EHLO five.pairlist.net
>   Out: 250-xerxes.robinson-west.com
>   Out: 250-PIPELINING
>   Out: 250-SIZE 40960000
>   Out: 250-ETRN
>   Out: 250-ENHANCEDSTATUSCODES
>   Out: 250-8BITMIME
>   Out: 250 DSN
>   In:  MAIL FROM:<coco-bounces at maltedmedia.com> SIZE=5737
>   Out: 250 2.1.0 Ok
>   In:  RCPT TO:<deemcr at robinson-west.com>
>   Out: 250 2.1.5 Ok
>   In:  DATA
>   Out: 354 End data with <CR><LF>.<CR><LF>
>   Out: 451 4.3.0 Error: queue file write error
>   In:  QUIT
>   Out: 221 2.0.0 Bye
>
>
> For other details, see the local mail logfile
You might get the same error with very different root causes!!
* postfix spool full, not mounted, not writable, ....
* when you use `before-queue' filtering and the filter mechanism is 
[temporarily] not accessible/not working as expected

I looked at the postfix sources (2.11.0) to see when that error is 
generated. It's all over the place:-( So it might not have much to do 
with the `SSD' at all!

>
> I have a 500 gig SSD on this server.  I can't find this in the local
> postfix logs.  Looked at the headers, nothing is obviously wrong.  The
> SSD is fairly new, less than 6 months old.  How do I find out if
> there has been a write error?  The SSD is a Samsung brand SSD.  I'm
> running CentOS 6.x updated.
S.M.A.R.T;-) should tell you when it was a real drive/HW problem. The 
output from my 3.25 year old Intel SSD (without errors):

root at feather4:~# smartctl --all /dev/sda
smartctl 6.2 2013-04-20 r3812 [x86_64-linux-3.11.0-19-generic] (local build)
Copyright (C) 2002-13, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Model Family:     Intel X18-M/X25-M/X25-V G2 SSDs
Device Model:     INTEL SSDSA1M160G2LE
Serial Number:    CVPO035201ZV160CGN
LU WWN Device Id: 5 001517 9593c0627
Firmware Version: 2CV102M3
User Capacity:    160,041,885,696 bytes [160 GB]
Sector Size:      512 bytes logical/physical
Rotation Rate:    Solid State Device
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   ATA/ATAPI-7 T13/1532D revision 1
SATA Version is:  SATA 2.6, 3.0 Gb/s
Local Time is:    Sat Apr 12 10:18:18 2014 PDT
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x00) Offline data collection activity
                                         was never started.
                                         Auto Offline Data Collection: 
Disabled.
Self-test execution status:      (   0) The previous self-test routine 
completed
                                         without error or no self-test 
has ever
                                         been run.
Total time to complete Offline
data collection:                (    1) seconds.
Offline data collection
capabilities:                    (0x71) SMART execute Offline immediate.
                                         No Auto Offline data collection 
support.
                                         Suspend Offline collection upon new
                                         command.
                                         No Offline surface scan supported.
                                         Self-test supported.
                                         Conveyance Self-test supported.
                                         Selective Self-test supported.
SMART capabilities:            (0x0003) Saves SMART data before entering
                                         power-saving mode.
                                         Supports SMART auto save timer.
Error logging capability:        (0x01) Error logging supported.
                                         General Purpose Logging supported.
Short self-test routine
recommended polling time:        (   1) minutes.
Extended self-test routine
recommended polling time:        (   1) minutes.
Conveyance self-test routine
recommended polling time:        (   1) minutes.

SMART Attributes Data Structure revision number: 5
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE UPDATED  
WHEN_FAILED RAW_VALUE
   3 Spin_Up_Time            0x0020   100   100   000    Old_age 
Offline      -       0
   4 Start_Stop_Count        0x0030   100   100   000    Old_age 
Offline      -       0
   5 Reallocated_Sector_Ct   0x0032   100   100   000    Old_age 
Always       -       3
   9 Power_On_Hours          0x0032   100   100   000    Old_age 
Always       -       13791
  12 Power_Cycle_Count       0x0032   100   100   000    Old_age 
Always       -       1396
192 Unsafe_Shutdown_Count   0x0032   100   100   000    Old_age 
Always       -       69
225 Host_Writes_32MiB       0x0030   100   100   000    Old_age 
Offline      -       117615
226 Workld_Media_Wear_Indic 0x0032   100   100   000    Old_age 
Always       -       7756485
227 Workld_Host_Reads_Perc  0x0032   100   100   000    Old_age 
Always       -       2
228 Workload_Minutes        0x0032   100   100   000    Old_age 
Always       -       2957599256
232 Available_Reservd_Space 0x0033   100   100   010    Pre-fail 
Always       -       0
233 Media_Wearout_Indicator 0x0032   100   100   000    Old_age 
Always       -       0
184 End-to-End_Error        0x0033   100   100   090    Pre-fail 
Always       -       0

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
Num  Test_Description    Status                  Remaining 
LifeTime(hours)  LBA_of_first_error
# 1  Vendor (0xf0)       Completed without error       00% 1350         -

SMART Selective self-test log data structure revision number 0
Note: revision number not 1 implies that no selective self-test has ever 
been run
  SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
     1        0        0  Not_testing
     2        0        0  Not_testing
     3        0        0  Not_testing
     4        0        0  Not_testing
     5        0        0  Not_testing
Selective self-test flags (0x0):
   After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

Hope that helps;-)
-- Marco

>
>
> _______________________________________________
> svlug mailing list
> svlug at lists.svlug.org
> http://lists.svlug.org/lists/listinfo/svlug





More information about the svlug mailing list