[svlug] RANT: Ubuntu is Evil

Brian J. Tarricone bjt23 at cornell.edu
Sat Jan 16 20:08:36 PST 2010


Ok, time for some troll-feeding...

On 01/15/2010 06:26 PM, Chris Miller wrote:

> I prefer to use the Sun JRE.  No real reason, only that I've been
> using the Sun JRE since 1.4.2 and I just don't want to change.  I
> don't want to have to figure out what's different, or anything.  The
> Sun JRE is free as in the free samples at Costco, and I've never had
> any problems with it.

So you don't want to learn about the technologies you use, and what your
options are regarding them, including pros and cons of the various
choices, and at least a passing understanding of their differences.

Got it.  Let's move on...

> The new EC2 instance runs Ubuntu Server 9.10 [instead of 9.04].

Why?  Was there something missing in 9.04 that you needed?  Did someone
unwittingly install the newer version thinking it was better?  Seems
like your solution from the get-go was, "hmm, I know this works on 9.04;
if I want the quickest path to get this running, I should reinstall with
9.04 before I even try anything else."

If you *really* wanted to upgrade to 9.10 for some reason, you can do
that later on, at your leisure, using a separate test system.

> Evidently you cannot get the Sun JRE from an Ubuntu repository in
> 9.10.

Well, maybe Server is different (I doubt it), but that's patently false:
http://packages.ubuntu.com/karmic/sun-java6-jre

Perhaps that requires enabling the 'multiverse' repository (if it isn't
enabled already), but that's hardly a huge hurdle.

> but unfortunately the GlassFishv2 package is also missing from
> the 9.10 repository.

Unfortunate.  Did you attempt to find out why it wasn't included, or are
you just going to whine and imply that Canonical is out to get you?

> What they did have was a series of packages for glassfish (that I had
> to take on blind faith were version 2, as Ubuntu's package version
> numbers are notorious for having a weak correspondence to the actual
> version of the software in question).  glassfish-j2ee and a bunch of
> others that didn't look like anything I needed.  So I installed
> glassfish-j2ee and hoped for the best.

Fail.  Did you bother looking at packages.ubuntu.com?  I came up with
this search about 10 seconds after opening the site:

http://packages.ubuntu.com/search?keywords=glassfish&searchon=names&suite=all&section=all

You can clearly see there that the non-v2 packages are a continuation of
the non-v2 packages in 9.04 (with even the same version numbers), and
that the v2 packages are indeed missing in 9.10.

> So after an overall of two hours I have the application back up and
> running, in spite of Ubuntu's efforts to completely undermine my
> attempt to repeat what I had done on Ubuntu 9.04.

Uh... so you did a major OS upgrade, and you think 2 hours is
unreasonable to get an app "ported" to the new version of the OS?
That's... silly, to put it nicely.  You got off easy.

> Aptitute says that I have the latest version of Ruby Gems.  This is
> Ubuntu 9.04.  With a feeling of impending doom, I began the
> dist-upgrade to 9.10.  My premonition of more BS to come was
> absolutely correct.

*jawdrop* You did a live dist-upgrade on a server that other people
depend on for day to day work?  Foolish, to say the least.

> Ubuntu decided that upgrading Apache was absolutely necessary.  I
> don't know why, the old version of Apache was working just fine.  Was
> there a reason to update?  No.  Just to appease the little monster
> that is the package version resolver or something.

You told it to dist-upgrade.  That means to update everything on the
system to the latest version.

Even *if* you canceled the dist-upgrade and tried to update individual
packages -- which is idiotic when you realize that doing so will put you
on two different versions of Ubuntu at the same time (what was that you
were saying earlier about it being foolish to mix repositories?) --
there still may have been a valid reason for the upgrade.  Some other
piece of software on the system might depend on a newer version of
Apache.  You've clearly demonstrated -- and directly admitted (bragged?)
-- thus far that you're lazy, so I'm sure you didn't bother to see if
perhaps there was an actual reason for the upgrade.

Packages get upgraded for all sorts of reasons.  Maybe the 9.04 version
of Apache was based off a version with bugs that later surfaced.  In the
interests of stability, the bugfix patches were likely backported to
that version and included in package updates.  When planning for 9.10, a
newer version of Apache was selected and tested.  Any backported patches
could be dropped, and any new functionality present in the new version
would be gained.  Unfortunately, sometimes there are incompatible
changes.  Working around those across a major OS upgrade can be prohibitive.

> This takes /var/www and moves it to /var/www-backup, and changes all
> the permissions to root as well.  Not that they ever tell me they're
> replacing my web directory with the Apache default - which they
> don't.  Evidently I'm supposed to be clairvoyant and simply know that
> they're going to wipe my user data while they're upgrading what
> should only be to the application binaries and what not.

Moving != wiping.  Your data was totally intact and trivially findable.
 Though I'd agree that the package should treat /var/www as
"configuration data" in the same way files under /etc would be.

> Anyways, I upgrade to 9.10, which lets me increase my version of Ruby
> Gems by 1 minor version.  Hooray.  I run rake db:migrate, which still
> isn't on the PATH.  I run /var/lib/gems/1.8/bin/rake db:migrate and
> it demands I upgrade Rails.  I do so.  I run rake again and it tells
> me to upgrade rails.  I change a Ruby file which gets rake to pull
> its head out of its rear end and look in the gems folder instead of
> echoing the reminder to me a million times.

At this point it occurs to me to question why you're always blaming
Ubuntu, and not Ruby/rake/Rails/etc.  *Those* are the components that
are complaining to you about dependencies that are too old.  Why don't
they share any of the blame?  By your logic, clearly they're dependent
upon newer versions of the software for some capricious, arbitrary reason.


> After poking through /etc/apache2/sites-available (and looking
> through /etc/apache2/sites-enabled, just to be sure) I determined
> that /var/www is the web directory (as it very well should be!)  I
> look at the web directory and it's an Apache default one.  I'm
> absolutely horrified.  I wasn't the one who installed Wordpress, so
> for all I know I just wiped out the entire freaking customer-facing
> website without knowing it.  Which is depressing, because I had
> dutifully backuped up the MySQL database beforehand, as well as
> /opt.

Again: you did an in-place major OS upgrade on a live server without
*backing up the entire server*.  I have no sympathy.

Anyway, I'm getting tired of this.  Have fun continuing to blame others
for your blunders.

	-brian




More information about the svlug mailing list