[svlug] Error building VMware

Rick Moen rick at linuxmafia.com
Mon Jan 19 18:43:02 PST 2009


Quoting Skip Evans (skip at bigskypenguin.com):

> I got the file
> vmware-any-any-update115.tar.gz
> 
> From that link and ran the runme.pl file, but got the same 
> compile error as before.

Going by the cited diagnostic, the proprietary VMware code that needs to 
parse and use Linux kernel source code had been having a difficult time
navigating and using the kernel header files you say you installed.  The
vmware-any-any tool can solve many VMware-adjustment problems, but not
all.

> But then I found a file here
> 
> http://www.insecure.ws/2008/10/20/vmware-specific-specific-55x-and-kernel-2627
> 
> Called
> vmware-update-2.6.27-5.5.7-2.tar.gz
> And it seems to have completed the install.

That appears to be a Perl script and set of accompanying update files
that revise the VMware kernel-related code for changes in the kernel 
programming interface through kernel 2.6.27.





More information about the svlug mailing list