[svlug] Switching wireless drivers

Skip Evans skip at bigskypenguin.com
Sat Jul 26 11:43:14 PDT 2008


Hey all,

Okay, the wireless on my new Ubuntu 8.04 Dell 
Vostro 1000 laptop with a Broadcom 1395 wireless 
interface is now working for the most part, but 
I've found I can't ssh to the servers here. (It 
works through the cable interface, just not the 
wireless.)

On Google I found people who have had the same 
problem, and one person said that he fixed it by 
removing the wl module and only using ndiswrapper.

So here's what I have:

When the laptop boots the wireless is functional 
for Internet through the Netopia modem on my LAN 
and shows a valid IP, Default Route, etc, and says 
  it's using "Driver: wl". (All this info comes 
from right clicking the blue bars at the top right 
and selection Connection Information.

If I do from a shell

ndisrapper -l

I get

bcmwl5 : driver installed
device (14E4:4315) present (alternative driver: wl)

bcmwl5 is the driver I installed and the device 
values are correct.

According to the guy who fixed this same problem 
he did

rmmod wl
modprobe ndiswrapper

to remove wl and use only ndiswrapper

But after doing

rmmod wl

I still get the same driver information listed as 
above, and it still lists "alternative driver: wl"

So my question now is about wl, is this driver 
currently being used, and if so, why can't I 
remove it?

Thanks,
Skip
-- 
Skip Evans
Big Sky Penguin, LLC
503 S Baldwin St, #1
Madison, WI 53703
608-250-2720
http://bigskypenguin.com
=-=-=-=-=-=-=-=-=-=
Check out PHPenguin, a lightweight and versatile
PHP/MySQL, AJAX & DHTML development framework.
http://phpenguin.bigskypenguin.com/




More information about the svlug mailing list