[svlug] svlug Digest, Vol 310, Issue 19

bruce coston jane_ikari at yahoo.com
Mon Jun 26 13:08:34 PDT 2006

I have a bunch of cd's burned but not kaNOTix 64 for 64 bit machines , given how well kaNOTix works on various laptops it would have been my first choice. My page is http://b.coston.googlepages.com , I forget if i've mentioned any laptop stuff as it focuses on family desktop dialup 

svlug-request at lists.svlug.org wrote: Send svlug mailing list submissions to
 svlug at lists.svlug.org

To subscribe or unsubscribe via the World Wide Web, visit
or, via email, send a message with subject or body 'help' to
 svlug-request at lists.svlug.org

You can reach the person managing the list at
 svlug-owner at lists.svlug.org

When replying, please edit your Subject line so it is more specific
than "Re: Contents of svlug digest..."
Today's Topics:

   1. cleaning "j" keyboard mouse (pointer) (Daniel)
   2. cheap machine and Linux installation woes (Alex Martelli)
From: Daniel <k6dlc at arrl.net>
Subject: [svlug] cleaning "j" keyboard mouse (pointer)
Date: Sun, 25 Jun 2006 12:36:30 -0700
To: svlug at lists.svlug.org

   What is the best way to clean the "j" keyboard mouse on a laptop? This 
is the one that looks like a pencil eraser head.
Thank you,


PGP: AD5A 96DC 7556 A020 B8E7 0E4D 5D5E 9BA5 C83E 8C92

From: Alex Martelli <aleaxit at gmail.com>
Subject: [svlug] cheap machine and Linux installation woes
Date: Sun, 25 Jun 2006 17:56:41 -0700
To: svlug at lists.svlug.org

 Hi all, I'm new to this list (but was at the installfest last  
Saturday... at least the part _after_ the US/Italy World Cup game...  
trying to help my wife get Ubuntu onto her P1520, alas unsuccessfully).

I'm pretty good at Linux, but it had been a while since I installed  
it (at work it's pre-installed, at home I've basically switched to  
Macs); recently I let myself be tempted by a TigerDirect offer, just  
$249, for:

eMachines D6417 AMD Athlon 64 3200+ 2.0GHz / 256MB DDR / 80GB HDD /  
DVD�RW DL / Flash Media Reader / Windows XP Home / Refurbished  
Desktop PC (E400-D6417)

I have some computationally intensive "background" stuff that I want  
to run and this sounded like good value for money. Unfortunately, the  
box arrived just _after_ the installfest, so I took installing Linux  
on it (ideally in a dualboot arrangement with XP, just in case I ever  
need that flash-media reader or whatnot) as this weekend's fun task.

First I tried Ubuntu 6.06 for AMD64: kernel panic during startup.  I  
thought it might be the memory, and wanted more than 256 MB anyway,  
so I bought 512 MB at a nearby shop, installed that, and -- identical  
kernel panic with the AMD64 Ubuntu 6.06.

Next I tried Ubuntu 6.06 for i386: starts OK, but for some reason  
insists on keeping the screen fixed at 640x480 (every other OS I  
tried drives the screen at 1280x1024 without problems) *AND* there is  
no way to have the "choose language" first window of the installation  
work at that resolution -- some crucial button is hidden below the  
lower edge of the screen and I just can't move past that first  
window.  Trying to boot Ubuntu with "safe graphics" actually tries to  
drive the screen to some wild level (I know because the LCD monitor  
is smart enough to complain with a big red box if anything tries to  
drive it beyond its limits of 1280x1024!).

Next I tried Gentoo 2006, Universal Install disc for AMD64; kernel  
panic during startup (in a different way than Ubuntu).

Next I tried Mandriva One 2006 (I believe it's i586 or something like  
that): boots and works fine as a "live" distribution, so I wanted to  
install it to the hard disk.  Alas, Mandriva's partitioning utility  
keeps complaining that there's something wrong with the NTFS  
partition (Win/XP', which took up the whole disk and I want to  
shrink) and saying I should chkdsk; I do get into XP, chkdsk /f, shut  
down cleanly, back to Mandriva, but the partitioning utility keeps  
failing with exactly the same error message.

So I try the GPartEd standalone CD; kernel panic during startup with  
very specific problems with USB.  So I get into the BIOS, turn off  
all USB support, reboot GPartEd, this time it starts fine -- but the  
gparted GUI says "scanning all drives" with a bouncing scrollbar and  
keeps bouncing forever.  If I kill it and restart it from the icon it  
keeps having that behavior; if I start it from the commandline  
instead it doesn't scan drives, rather it says it has no drives (and  
finds none if I tell it to rescan) and thus doesn't do anything.

Giving up on keeping XP around (and fully knowing I'll want to  
reinstall Linux at some point anyway, since Mandriva's not my  
favourite distro, and I _would_ really like to use that Athlon as  
AMD64, not just as an i386 or whatever...!-)), I go to Mandriva One  
again, and have it wipe the disk and take it over as it wishes.  It's  
quite a "pared-down" distro though... I manage to get networking  
configured, kinda sorta (a story in itself... see below), add an  
update site, and get some minimum survival subset (e.g., that's the  
only way to get sshd up!-), but many of the packages (e.g., Apache)  
just won't install because of dependencies which are apparently NOT  
in the list of RPMs one can get for this distro.  I definitely want  
to move to a better distro ASAP...:-(.

All of this was punctuated by frequent downloading and CD-burning, of  
course; I think I've downloaded and burned more ISO images yesterday  
than in any previous day of my life!-)

BTW, the specific problem with networking...: the machine sits in a  
small study room which is not cabled -- internet access (via comcast  
cable) comes from the living room where an Airport Express connects  
to the cable modem and routes access via 801.11g; in the study, to  
serve the needs of a Powermac (bereft of wifi), I have an Airlink 101  
AP421W, a flexible access point configured to just rely connectivity  
between the WLAN and its Ethernet port -- the Powermac's pretty happy  
with it...

...the eMachines box with Mandriva One, however, is only "kinda  
sorta" happy: specifically, it keeps changing IP address  
periodically!  I'm not sure why it can't just happily keep its DHCP  
lease like every other machine in the house, but it clearly can't.   
It was when first working, a few hours ago; it's up to now, and I've seen it use .15 and later .16 at in-between  
times.  No doubt it's asking the DHCP server (the Airport Express, by  
transparent pass-through via the Airlink) for a new lease each time  
one expires, in some way that just won't let the AE simply renew the  
previous lease (?).  I could debug that, I guess, but since I plan to  
get a "better" install anyway, I'd rather not spend time on that!-)   
Even though this behavior makes it pretty hard to ssh to the box to  
do anything useful, and I'd rather not have to be walking back to  
that study all the time...

So -- any advice is welcome!  Ubuntu's my favorite distro, but I  
could live with another -- as long as it let me use my Athlon as an  
AMD64, make use of updated versions of development tools and  
libraries (gcc 4.1 etc, python 2.4.3, and the like), and do minimal  
networking with reduced amounts of fuss.  I don't really need much  
from the box, since I'll mostly be using it for development and to  
run very long running, computationally intensive "batch" programs;  
while I'd like to be able to access the machine with X11 as well (via  
ssh -Y, typically), even that is not really a must -- I could live  
with multiple virtual-terminal access for occasional console use, and  
plain ssh for typical "remote" (from the living room...;-) use.

I've tried all the single-CD-to-download, reasonably-updated- 
components distros I could think of, but I expect there are others  
(if the current craze for "live-only" distros with no HD install  
hasn't wiped them out).  I _could_ download more CDs if needed, or,  
preferably, buy them (ideally from a local merchant, Palo Alto or  
Mountain View or vicinity, but I guess I can order on the net if  
that's the only way;-), if that's the only sensible way to get there  
from here. I can give more details, e.g. about the kernel panics of  
Ubuntu and Gentoo in AMD64 mode, if some superexpert thinks they  
could help diagnose and fix things (the BIOS settings go on for 12  
screens and I understand maybe half of the acronyms they  
contain...;-), but that means reproducing the crash and typing info  
off that screen by hand, so I hope there's an easier way...!-).

Anyway, thanks for listening!, and thanks in advance for any help you  
might offer!


svlug mailing list
svlug at lists.svlug.org

Yahoo! Sports Fantasy Football ’06 - Go with the leader. Start your league today! 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.svlug.org/archives/svlug/attachments/20060626/57bafce1/attachment.htm

More information about the svlug mailing list