[svlug] No Networking In Gentoo

Lord Sauron lordsauronthegreat at gmail.com
Sun Apr 9 13:42:14 PDT 2006


On 4/9/06, Dan Martinez <dfm at razorwind.org> wrote:
> 1. Is the network card being detected? The output of 'dmesg' would be useful.
>
>     dmesg | grep eth
>
> might give a few clues, although it would probably be better to say
>
>     dmesg | less
>
> and search for 'eth', just to get the surrounding context.
>
> 2. Does the output of 'ifconfig' show that the system is aware of the
> presence of eth0?
>
> 3. What happens if you run
>
>     /etc/init.d/net.eth0 start
>
> by hand?

Well, by now I think we've found that eth0 is horribly misconfigured. 
I'll just skip this if no one minds.

> 4. Are the 'hotplug' and 'coldplug' packages installed? Are they
> configured to run at boot time? You're not going to get many modules,
> including network modules, loaded automatically without them.What's
> does
>
>     emerge -p hotplug coldplug

Sorry, no networking.  emerge doesn't work.

> say?
>
> What does
>
>     rc-status --all
>
> say?
>
> If you can provide the requested items -- dmesg output, ifconfig
> output, results of attempting to manually start net.eth0, and the
> output of the above emerge and rc-status commands -- we'll be in a
> *much* better position to help you. (That's *output*, not just
> results. Hint, hint, nudge, nudge.)

I also try to filter out the misc. stuff, but now I think I need to
figure out how to get eth0 to be properly configured.  I don't think
eth0 is a physical device, since it lacks an interrupt and a base
address.

--
========== GCv3.12 ==========
GCS d-(++) s+: a? C++ UL+>++++ P+
L++ E--- W+(+++) N++ o? K? w--- O? M+
V? PS- PE+ Y-(--) PGP- t+++ 5? X R tv-- b+
                DI+++ D+ G e* h- !r !y
========= END GCv3.12 ========




More information about the svlug mailing list