[svlug] HP 5500 Series Printers

James Sparenberg james at linuxrebel.us
Wed Mar 23 19:45:09 PST 2005


On Wed, 2005-03-23 at 17:56, Thomas G. Digby wrote:
> I have a new HP Officejet 5510 printer/scanner (USB interface).  I
> verified that it worked on my Windows98 machine, and now I'm moving it
> over to my Linux box.
> 
> I've been able to print from Linux, but not to scan.
> 
> I tried running sane-find-scanner as an ordinary user and as root and got 
> different results.  Here's what's different between the two outputs (done 
> by redirecting both to files and then doing diff):
> 
>     *****************
> 
>  < found USB scanner (vendor=0x03f0, product=0x3a11) at libusb:002:003
>  ---
>  > found USB scanner (vendor=0x03f0 [hp], product=0x3a11 [officejet 5500
>  series])
>   at libusb:002:003
>  19,22d18
>  <
>  <   # You may want to run this program as root to find all devices. Once
>  you
>  <   # found the scanner devices, be sure to adjust access permissions as
>  <   # necessary.
> 
>     *****************
> 
> In other words, sane-find-scanner can get the vendor info as root but not 
> as an ordinary user, although it sees the hardware either way.
> 
> So is there some permission setting I need to change, or a file I need to
> copy to a different directory, or what?  
> 

Some pages that might help (I don't have this printer myself.)

http://www.linuxprinting.org/show_printer.cgi?recnum=HP-OfficeJet_5500

the HP FAQ (section 29 should be the one you need.)

http://www.linuxprinting.org/hp-faq.html

FAQ;s.org HP Linux HowTo

http://www.faqs.org/docs/Linux-HOWTO/HP-HOWTO.html

James






More information about the svlug mailing list