[svlug] HP 5500 Series Printers

Thomas G. Digby bubbles at well.com
Wed Mar 23 17:56:48 PST 2005


I have a new HP Officejet 5510 printer/scanner (USB interface).  I
verified that it worked on my Windows98 machine, and now I'm moving it
over to my Linux box.

I've been able to print from Linux, but not to scan.

I tried running sane-find-scanner as an ordinary user and as root and got 
different results.  Here's what's different between the two outputs (done 
by redirecting both to files and then doing diff):

    *****************

 < found USB scanner (vendor=0x03f0, product=0x3a11) at libusb:002:003
 ---
 > found USB scanner (vendor=0x03f0 [hp], product=0x3a11 [officejet 5500
 series])
  at libusb:002:003
 19,22d18
 <
 <   # You may want to run this program as root to find all devices. Once
 you
 <   # found the scanner devices, be sure to adjust access permissions as
 <   # necessary.

    *****************

In other words, sane-find-scanner can get the vendor info as root but not 
as an ordinary user, although it sees the hardware either way.

So is there some permission setting I need to change, or a file I need to
copy to a different directory, or what?  


-- 
                       -- Tom Digby
                       bubbles at well.com
                       http://www.well.com/~bubbles/ 
                       http://www.well.com/~bubbles/BblB60DL.gif




More information about the svlug mailing list