[svlug] Webalizer has me stumped =(

Richard Gardner noeffort at comcast.net
Mon Mar 21 23:14:42 PST 2005


Background.

Single Redhat webserver running an "elearning" site that points to links of
Webex recorded sessions for our internal product manager bi-weekly
bull-sessions.

[root at cassini httpd]# ls -ltr access_log*
-rw-r--r--  1 root root 23921 Mar 19 15:29 access_log.4
-rw-r--r--  1 root root 23016 Mar 19 15:29 access_log.3
-rw-r--r--  1 root root  6150 Mar 19 15:29 access_log.2
-rw-r--r--  1 root root 36369 Mar 19 16:27 access_log.1
-rw-r--r--  1 root root     0 Mar 20 04:02 access_log

I was able to run stats using webalizer when the log you see now named as
access_log.1 was the current access_log.

The proglem is this. The other logs were un-tar'd from the previous
"cassini" webserver instance.  I had to rebuild from a hardware based
machine to a vm.  That was no problem except that the "old" webserver logs
now had to be imported over in order to preserve the historical log data.

I have tried all the "duh" things like running:

# webalizer access_log
# webalizer access_log.1

I tried concatenating the logs into one large file also.

But even after deleting all 3 tracking/history files in /var/lib/webalizer
it will still only report on the data that was originally captured when I
ran against "access_log" the first time - which was the incomplete data.

I am overlooking something stupid?  (I'm sure I am, it usually is a "duh"
thing)

Anyway, any help appreciated, TIA, Richard.





More information about the svlug mailing list