[svlug] Sound is broken

Tim tim at tetro.net
Mon May 19 13:24:09 PDT 2003


On Mon, May 19, 2003 at 08:51:51AM -0700, Larry Colen wrote:
> I tried adding that line, still no joy. I shouldn't have to reboot for
> the changes to take place should I?

No reboot needed.  Rebooting is only necessary for booting a new or
different kernel image (/boot/vmlinuz*) and for hardware maintainance.
modprobe complains if /etc/modules.conf is newer than
/lib/modules/`uname -r`/modules.dep, so running depmod -a after changing
/etc/modules.conf is probably recommended, but I doubt it will fix your
problem.  

> I can't even find out what sound-service-0-3 is or where it comes
> from. locate doesn't find it, neither does a grep of /etc

Quoting Documentation/modules.txt in the kernel source tree, it is "a
symbolic description of a requested feature".  It would be nice to have
an up-to-date list of these features and what they are for distributed
with each kernel though, wouldn't it?  I suppose you could always grep
-r the kernel source and deduce it yourself, but that might not be an
option for the non-programmer users.

What seems to be happening, this is just a guess by the way, is that the
emu10k1 driver is loading, detecting a supported card, but for some
reason not registering the sound DSP (accessible through /dev/dsp).
Maybe a prerequisite that emu10k1 needs is missing from the kernel.. but
wouldn't that cause some depmod errors about unresolved symbols?  I
don't know.

Can you upload your kernel's .config file (it might be too big to send
to the list) somewhere?  It is located in the directory where you ran
your:

  make dep; make; make modules; make modules_install

commands from.  Also the output of 'lspci -v', 'cat /proc/interrupts',
and 'uname -r' might be useful in figuring out the problem.

If you want, you can upload that info to this little PHP script I wrote
and include the URL(s) it gives you in your reply:

  http://tetro.net/misc/nopaste.php

   - Tim




More information about the svlug mailing list