[svlug] ATI 8500DV and GATOS setup

Ryan Joseph ryan at ryanjoseph.com
Fri May 9 05:59:31 PDT 2003


> Can you post the output of glxinfo?  What version of XFree86?  Did you
> apply any kernel patches (drm) to match the requirements of your
> versions of X, kernel, and card?

glxinfo:
----
name of display: :0.0
display: :0  screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4
OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
    GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
    GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess
 
   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 16 tc  1 16  0 r  y  .  5  6  5  0  0 16  0  0  0  0  0  0 0 None
0x24 16 tc  1 16  0 r  y  .  5  6  5  0  0 16  8 16 16 16  0  0 0 None
0x25 16 tc  1 16  0 r  y  .  5  6  5  8  0 16  8 16 16 16 16  0 0 None
0x26 16 tc  1 16  0 r  .  .  5  6  5  8  0 16  8 16 16 16 16  0 0 None
0x27 16 dc  1 16  0 r  y  .  5  6  5  0  0 16  0  0  0  0  0  0 0 None
0x28 16 dc  1 16  0 r  y  .  5  6  5  0  0 16  8 16 16 16  0  0 0 None
0x29 16 dc  1 16  0 r  y  .  5  6  5  8  0 16  8 16 16 16 16  0 0 None
0x2a 16 dc  1 16  0 r  .  .  5  6  5  8  0 16  8 16 16 16 16  0 0 None
----

I'm using XFree 4.3.0, and the gentoo-packaged ati-gatos drivers.  I
compiled and installed the drm kernel module from the ati-gatos website
and have that loaded.  I actually managed to get glx working, but now a)
my display is running *really* slowly (updating every half a second or
more it seems like), and when I run xawtv, it doesn't crash, but cannot
tune to any channels and seems to tune incredibley slowly.

I have satisfied all the requirements mentioned on the gatos page, so I
have no clue what could be casuing this.  Thanks for the help!

--ryan

-- 
Ryan P. Joseph                                  ryan at ryanjoseph.com
http://ryanjoseph.com                           rjoseph at calpoly.edu
-------------------------------------------------------------------
I use PGP, you should too:             http://ryanjoseph.com/?z=pgp




More information about the svlug mailing list