[svlug] My computers give each other the silent treatment (revisited)

Scott Thompson scott_thompson at earthlink.net
Thu May 8 15:00:05 PDT 2003


My original email was rather lean on information about my problem.   It 
is restated here with more detail.

In summary, both machines used to talk to each other, now they don't. 
The  only thing that changed was I Installed Apache(1.3.26) and 
PHP(4.1.2) on the Linux machine so I could do some web development.

I get the following error message on my Linux Machine:
<snip>
.
.
.
NETDEV WATCHDOG: eth0: transmission timed out
eth0: Transmission timed out, status 02261000, CSR12 00000030,\
resetting...
.
.
.
ad infinitum (it fills a text console)
</snip>

I googled and discovered that this was a bug in the tulip driver in the 
late 2.3.x kernels and early 2.4.x kernels, but haven't been able to 
discover if it was a problem in the 2.4.18 kernel (which I happen to 
use).  See below...

Vital network information
---------------------------
- Debian Linux and Win2K machine networked peer-to-peer
- Static IP's (no Internet access)
- Both NIC's are Kingston KNE110TX (tulip driver in Linux)

Vital Linux Information
-------------------------
akhnaton:~# uname -a
Linux akhnaton 2.4.18-686 #1 Sun Apr 14 11:32:47 EST 2002 i686 unknown
akhnaton:~# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:C0:F0:5A:E3:29
           inet addr:192.168.22.35  Bcast:192.168.22.255  Mask:255.255.255.0
           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
           RX packets:372 errors:0 dropped:0 overruns:0 frame:0
           TX packets:324 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:100
           RX bytes:42960 (41.9 KiB)  TX bytes:27997 (27.3 KiB)
           Interrupt:9 Base address:0x1400

akhnaton:~# cat /etc/network/interfaces
# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
auto lo
iface lo inet loopback

# Network Interface
auto eth0
iface eth0 inet static
	address 192.168.22.35
	netmask 255.255.255.0
	network 192.168.22.0
	broadcast 192.168.22.255
	# gateway 192.168.22.31
akhnaton:~# cat /proc/pci
<snip>
.
.
.
   Bus  0, device  16, function  0:
     Ethernet controller: Lite-On Communications Inc LNE100TX (rev 32).
       IRQ 9.
       Master Capable.  Latency=64.
       I/O at 0x1400 [0x14ff].
       Non-prefetchable 32 bit memory at 0xf4008000 [0xf40080ff].
   Bus  1, device   0, function  0:
.
.
.
</snip>

akhnaton:~# insmod tulip
Using /lib/modules/2.4.18-686/kernel/drivers/net/tulip/tulip.o
insmod: a module named tulip already exists


Any ideas?
-- 
Regards,
~Scott Thompson






More information about the svlug mailing list