FW: [svlug] confusing 'mount' error

Driver, Diron ddriver at primephotonics.com
Tue Jan 14 09:03:34 PST 2003


Thanks for the suggestions James, but it didn't work.  I tried mounting
the floppy even after I removed the /dev/fd0 point, still gave me wrong
major or minor number error.  I'm starting to think that something did
screw up with either the kernel or a module that the floppy drive uses.
I can mount other HD partitions, just no other block devices.  I tried
installing the DOC driver called doc.o and it gave me some unresolved
symbol errors, which means another module isn't installed or is missing
from the kernel, right?.  I think that might be my problem.  So what is
the module called that handles floppy operation??  I don't know if it
was compiled in or modularized (but I would guess compiled in).

Anyone have any clues??  

BTW, the unresolved symbols are "end_that_request_last_#####" and
"end_that_request_fist_#####" with some number/letter combinations at
the end.

-Diron

*************************
Diron Driver
Electrical Design Engineer
Prime Photonics, LC
1750 Kraft Drive, Suite 1000-A
Blacksburg, VA  24060
Office: 540.961.2200 x204
Cell: 540.819.7192
ddriver at primephotonics.com

-----Original Message-----
From: James Leone [mailto:linuxcpa at netscape.net] 
Sent: Monday, January 13, 2003 5:56 PM
To: Driver, Diron
Cc: svlug at lists.svlug.org
Subject: Re: [svlug] confusing 'mount' error

Hi Divon...

Sorry, I thought you were completely new.   :-[  My bad.

You probably know just as much as I do...

Anyway, I don't know too much beyond the basics.

But who knows, my gut says point you to this page:

http://www.lanana.org/docs/device-list/devices.txt

Its called Linux Allocated Devices and it is the official registry of 
allocated device numbers.

Gosh, I have only done this a few times, but I seem to remember a 
command called "mknod."

I remember for the Handspring Visor that I had to issue a command like
so:

mknod /dev/ttyUSB0 c 188 0

When I look at the Linux Allocated Devices booklet, it says:

188 char    USB serial converters
    0 = /dev/ttyUSB0    First USB Serial Converter
    1 = /dev/ttyUSB1    First USB Serial Converter

Of more importance:

2 block         0 = /dev/fd0    Controller, drive 0, autodetect
My guess:

 mknod /dev/fd0 b 2 0

James Leone

P.S. If it works let me know, cause I just learned something....









Driver, Diron wrote:

>James,
>
>I am using RedHat 7.0 and I do not have X-windows installed.  It is a
>very simple partition that we are supposed to use for kernel
compilation
>for use on a DOC (Disk-On-Chip) supplied with an industrial computer.
>Sorry, I forgot to mention my distro because I thought I already had
>(I've written this plea on a few different forums).
>
>As for your questions, yes, I have a /mnt/floppy point from my root
>partition.  FSTAB is correct for the automatic mounting of /mnt/floppy.
>I can't give you the exact contents of my fstab file right now as I am
>currently installing RedHat on a partition that just died on me.  I
>think static shock might have fried a few sectors of my HD because fsck
>can't repair it, too many bad inodes.
>
>Mounting the floppy drive used to work, now it doesn't.  I've never
seen
>this error before.  Maybe I didn't umount the device and turned power
>off??  I think I remember a friend in college screwing up his Linux
>install by doing that, and I may have done that as well.  I am working
>on an embedded system that uses a standard industrial PC.
>
>-Diron
>
>-----Original Message-----
>From: James Leone [mailto:linuxcpa at netscape.net] 
>Sent: Monday, January 13, 2003 4:52 PM
>To: Driver, Diron
>Cc: svlug at lists.svlug.org
>Subject: Re: [svlug] confusing 'mount' error
>
>Hi Diron,
>
>Before I get into the technical stuff,
>
>If you do not have Mandrake then try this...
>
>Open up a shell and type this:
>
>mount /mnt/floppy
>
>If you have Mandrake, click on the home icon and then click on the up 
>arrow until you see some folders labeled:
>
>bin
>boot
>command
>dev
>etc
>
>
>Click on the folder labeled "mnt"
>
>Wait a few seconds, then you will see some folders appear. Click on 
>floppy and your disk should be mounted.
>
>
>If that works and you are using a GUI, right click on your desktop and 
>say create new floppy device and pick /mnt/floppy as the device.
>
>If that doesn't work...
>
>Can I ask you a few questions so I can sort out what is going on?
>
>What distribution are you using?
>
>Can you do me a favor? Can you log in as root and post the contents of 
>/etc/fstab....
>
>...this file will tell me a little bit about what may be happening....
>
>Also, is there a directory called /mnt/floppy or /media/floppy in the 
>Linux partition?
>
>
>James Leone
>
>
>
>Driver, Diron wrote:
>
>  
>
>>Hey all,
>>
>>I'm new to this group, but I really need some help with a confusing 
>>mount error. I'm trying to mount the floppy device '/dev/fd0' and 
>>mount keeps telling me that '/dev/fd0' has wrong major or minor 
>>number. . . what the heck does this mean?? I don't know how I screwed 
>>up the mount or device, but it looks ok in /dev. All the access 
>>permissions look ok, how do I fix this??? Any help is greatly
>>    
>>
>appreciated.
>  
>
>>Thanks.
>>
>>*************************
>>
>>Diron
>>
>>----------------------------------------------------------------------
-
>>    
>>
>-
>  
>
>>_______________________________________________
>>svlug mailing list
>>svlug at lists.svlug.org
>>http://lists.svlug.org/lists/listinfo/svlug
>> 
>>
>>    
>>
>
>  
>

-- 
Your favorite stores, helpful shopping tools and great gift ideas. 
Experience the convenience of buying online with Shop at Netscape! 
http://shopnow.netscape.com/





More information about the svlug mailing list