[svlug] Zaurus and routing

Neil Kittipalo kpneil at haube.org
Tue Aug 12 22:31:10 PDT 2003


I've been given a Zaurus SL-5500. At the moment I only have the serial 
cable - no cradle & USB.

I want to be able to try it out on the internet. I can now make a ppp 
link over the serial link to my desktop and can ssh etc to the desktop.
I am so far unable to get out through my gateway.

The gateway and desktop are connected by a LAN, my internet is via a 
modem. I know my routing must be wrong but after 2 days I am getting 
nowhere!

The gateway has:


Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use 
Iface
203.149.1.77    0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
192.168.168.0   0.0.0.0         255.255.255.0   U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         203.149.1.77    0.0.0.0         UG    0      0        0 ppp0

The desktop has:

eth0      Link encap:Ethernet  HWaddr 00:01:02:28:13:C8
           inet addr:192.168.168.1  Bcast:192.168.168.255 
Mask:255.255.255.0
           inet6 addr: fe80::201:2ff:fe28:13c8/64 Scope:Link
           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
           RX packets:49651 errors:0 dropped:0 overruns:0 frame:0
           TX packets:48782 errors:0 dropped:0 overruns:0 carrier:0
           collisions:42
           RX bytes:19061321 (18.1 Mb)  TX bytes:8185041 (7.8 Mb)

lo        Link encap:Local Loopback
           inet addr:127.0.0.1  Mask:255.0.0.0
           inet6 addr: ::1/128 Scope:Host
           UP LOOPBACK RUNNING  MTU:16436  Metric:1
           RX packets:669 errors:0 dropped:0 overruns:0 frame:0
           TX packets:669 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0
           RX bytes:43720 (42.6 Kb)  TX bytes:43720 (42.6 Kb)

ppp0      Link encap:Point-to-Point Protocol
           inet addr:192.168.1.2  P-t-P:192.168.1.1  Mask:255.255.255.255
           UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
           RX packets:7 errors:1 dropped:0 overruns:0 frame:0
           TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0
           RX bytes:72 (72.0 b)  TX bytes:88 (88.0 b)

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use 
Iface
192.168.1.1     0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
192.168.168.0   0.0.0.0         255.255.255.0   U     0      0        0 eth0
0.0.0.0         192.168.168.4   0.0.0.0         UG    0      0        0 eth0

The Zaurus has:
lo        Link encap:Local Loopback
           inet addr:127.0.0.1  Mask:255.0.0.0
           UP LOOPBACK RUNNING  MTU:16436  Metric:1
           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:0
           RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

ppp0      Link encap:Point-to-Point Protocol
           inet addr:192.168.1.1  P-t-P:192.168.1.2  Mask:255.255.255.255
           UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
           RX packets:7 errors:0 dropped:0 overruns:0 frame:0
           TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:3
           RX bytes:88 (88.0 b)  TX bytes:72 (72.0 b)

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use 
Iface
192.168.1.2     0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
0.0.0.0         192.168.1.2     0.0.0.0         UG    0      0        0 ppp0

I have masquerading on the gateway and it is enabled for the ip 
addresses of the Zaurus. IP forwarding is ON on the desktop.

Has anyone done this? Have ideas? Or pointers?

Thank you.

Neil






More information about the svlug mailing list