[svlug] php install?

Robert Khachikyan rkhachik at sdsio.jpl.nasa.gov
Tue May 28 16:29:07 PDT 2002


Fellow SVLUG'ers,

I've recompiled the apache with the option --enable-module=so to allow PHP.
(am trying to add a php bboard)

Afterwards, I  ./configure --with-mysql --with-apxs=/path/to/apxs
and the following error is given:
checking for Apache 1.x module support via DSO through APXS... 

Sorry, I was not able to successfully run APXS.  Possible reasons:

1.  Perl is not installed;
2.  Apache was not compiled with DSO support (--enable-module=so);
3.  'apxs' is not in your path.  Try to use --with-apxs=/path/to/apxs
The output of /usr/local/apache/apache_1.3.19/bin/apxs follows
Usage: apxs -g [-S <var>=<val>] -n <modname>
       apxs -q [-S <var>=<val>] <query> ...
       apxs -c [-S <var>=<val>] [-o <dsofile>] [-D <name>[=<value>]]
               [-I <incdir>] [-L <libdir>] [-l <libname>] [-Wc,<flags>]
               [-Wl,<flags>] <files> ...
       apxs -i [-S <var>=<val>] [-a] [-A] [-n <modname>] <dsofile> ...
       apxs -e [-S <var>=<val>] [-a] [-A] [-n <modname>] <dsofile> ...
configure: error: Aborting


1) perl5 is installed
2) just recompiled with the --enable-module=so
3) file does exist, but it's as if trying to execute it w/o any parameters.


Has anyone played with php installation that can advise me on this error?
ThanX.


As Always,
...Robert



More information about the svlug mailing list