[svlug] RH dependencies, not using up2date

Isaiah Weiner iweiner at redhat.com
Sat Jul 27 14:20:50 PDT 2002


On Thu, Jul 25, 2002 at 02:11:51PM -0700, Marc MERLIN wrote:
> - rpm still doesn't have the option to auto pull dependencies in obvious
> cases (i.e rpm -i file.rpm, where all the dependencies are in the same
> dir)

    I don't see it in bugzilla.  When did you file it?

> - up2date is a joke
>   [root at localhost RPMS]# up2date -i redhat-config-network
>   Error Message:
>     Free service limited due to high load, please try again later (server 1001059607)
>   Error Class Code: 51

    I can understand your frustration, but I'm not sure how it differs from
a slashdotted website, or an FTP site with too many users, nor how it makes
the client a "joke."  Maybe some new jargon.

> - dependencies still suck.
>   [root at localhost RPMS]# rpm -i redhat-config-network-1.0.0-1.i386.rpm
>   gnome-core-1.4.0.4-54.i386.rpm libgnomeprint15-0.35-4.i386.rpm
>   rep-gtk-gnome-0.15-7.i386.rpm gdk-pixbuf-gnome-0.14.0-8.i386.rpm
>   rep-gtk-0.15-7.i386.rpm librep-0.15.1-3.i386.rpm
>   pygnome-libglade-1.4.2-3.i386.rpm pygtk-libglade-0.6.9-3.i386.rpm
>   libglade-0.17-5.i386.rpm sawfish-1.0.1-9.i386.rpm
>   error: failed dependencies:
>         libcapplet.so.0   is needed by gnome-core-1.4.0.4-54
>         libcapplet.so.0   is needed by sawfish-1.0.1-9
> 
>    How  am  I   supposed  to  know  that  libcapplet.so.0   comes  from  the
>    control-center package?

    If you have the rpmdb-redhat package you would be able to use
--redhatprovides option, as detailed in usage message for rpm.

    $ rpm --redhatprovides libcapplet.so.0
    control-center-1.4.0.1-31

> My question is simple:
> How can I install  RH packages (not contrib) with the  dependencies in a way
> that actually works (and  I want to be able to say where  my packages are, I
> don't want to pull them from some random place on the net)

    It's not complete, but try getting the latest up2date client errata nd
using the nodownload option.  It should sort out the dependencies and give
you a list, which you can use to fund your local package installation.
Granted, I haven't actually tried it.  Please do file an RFE in bugzilla if
you're that concerned with the feature.

-- 
    - Isaiah



More information about the svlug mailing list