[svlug] RH dependencies, not using up2date

Rafael Skodlar,,, raffi at linwin.com
Thu Jul 25 23:54:14 PDT 2002


Here is the answer with no answer:

Like everybody else I to go through the same RPM hell at work since our
customers use Redhat. While trying to setup decent workstation for
compiling OS stuff I run into all kinds of dependencies problems.
Wasting a lot of time I usualy give up after forth or fifth dependent
RPM fails to install. It was better in RH5.2 days.

There was an article on the web somewhere about RPM dependencies
problems recently. It's getting worse by the month and I'm not the only 
one noticing this. I tried all kinds of rpm tools but they are not ready
for prime time yet.

For that reason I decided to give Debian another try. I too want to be
a "lazy sysadmin" and use one line commands to install software. Debian
failed to work on my hardware earlier where RH and Mandrake would
install without major problems. Now that Debian 3.0 is out I started to
convert some critical systems to Debian. I have routers, NFS servers
etc. running on Debian just fine. Initial install takes less than 100MB
of disk space which speaks for itself.

In order to learn more about Debian I subscribed to 6 Debian lists. Due
to high level of spam on their mailing lists I dropped 3 right away.
Mention that on one of their lists and you'll draw flames and useless
"filter solution" suggestions from "Debian bigots". My impression was
that they are nontolerant elitist group that doesn't want around anybody
that's not religious fanatic like them. To me the OS is only a tool to
do my work more efficiently and debian seem to fit that description.

Progeny distribution based on Debian was promissing but failed in
commercial world. Worth noting is that Debian distribution has been
picked up by a major corporation recently so it's going to get more
"official support".

As a long time Redhat user and customer I'm disappointed to see them
ignore those who supported them through all these years. I bought many
boxes for work and home and never asked for help so their never used '30
day support' was clear profit for them. They could provide some kind of
transition to a better package management system, or even merge with
better Debian packaging tools, which was discussed years ago, but they
ignore the issue. They never improved their selection for type of system
installation and always introduce annoying bugs that should be noticed
before the release.

For that reason I can no longer recommend RH. My message to Redhat is
fix RPM mess and install process or else. And I won't pay for their
expensive "per system support" to get automatic bug fixes which should
be free on the first place.

Let the competition talk.

I see nobody came back with a solution to your (our?) problem so that
too talks for itself.


On Thu, Jul 25, 2002 at 02:11:51PM -0700, Marc MERLIN wrote:
> Ok, so I have to use Red Hat, and basically, all I can say is that in the
> 3.5 years I haven't touched it, it's not gotten much better.
> I've been working with RH 7.3 here
> 
> - rpm still doesn't have the option to auto pull dependencies in obvious cases
>   (i.e rpm -i file.rpm, where all the dependencies are in the same dir)
> 
> 
> - up2date is a joke
>   [root at localhost RPMS]# up2date -i redhat-config-network
>   Error Message:
>     Free service limited due to high load, please try again later (server 1001059607)
>   Error Class Code: 51
> 
>   I don't need rhn, besides I don't want to be pulling packages from RH,
>   I have them on my disk.
> 
>   In theory, it does what it need, but I think it's been designed to be hard
>   to use without talking to RH.
>   If someone has a howto on how to use up2date against a local repository of
>   RPMs, I'm listening.
> 
> 
> - dependencies still suck.
>   [root at localhost RPMS]# rpm -i redhat-config-network-1.0.0-1.i386.rpm gnome-core-1.4.0.4-54.i386.rpm libgnomeprint15-0.35-4.i386.rpm rep-gtk-gnome-0.15-7.i386.rpm gdk-pixbuf-gnome-0.14.0-8.i386.rpm rep-gtk-0.15-7.i386.rpm librep-0.15.1-3.i386.rpm pygnome-libglade-1.4.2-3.i386.rpm pygtk-libglade-0.6.9-3.i386.rpm libglade-0.17-5.i386.rpm sawfish-1.0.1-9.i386.rpm                                      
> error: failed dependencies:
>         libcapplet.so.0   is needed by gnome-core-1.4.0.4-54
>         libcapplet.so.0   is needed by sawfish-1.0.1-9
> 
>    How  am  I   supposed  to  know  that  libcapplet.so.0   comes  from  the
>    control-center package?
> 
> 
> - gnorpm doesn't seem to want to compute dependencies for local installs
>   gnorpm -i redhat-config-network-1.0.0-1.i386.rpm
>   tells me I'm missing dependencies
>   launching gnorpm and selecting a local package doesn't work any better.
> 
>   Now, if I do a web find, it will get those magic RDF files (which probably
>   contain the magic dependency to package name info), but for a package with
>   many recursive  missing dependencies like redhat-config-network,  it still
>   fails (it doesn't realize that control-center has further dependencies
> 
> 
> - rpmfind. I've had good luck with this in the past, besides its author,
>   Daniel Veillard, is a good friend, but I must be cursed because the version
>   that shipped with RH 7.3 doesn't seem to want to work on my system
> 
>   [root at localhost RPMS]# rm -rf ~/.rpmfind
>   [root at localhost RPMS]# rpmfind -v redhat-config-network
>   Host : deepthought.engr.intransa.com, Country: 840, Zones 0 0 0, Continent 1
>   Arch : i386, Os : Linux
>   Default distribution : Red Hat, Inc.(Red Hat Linux)
>           owning 453 of 456 installed packages
>   Get http://rpmfind.net/linux/RDF/resources/redhat-config-network.rdf
>   Fetching : http://rpmfind.net/linux/RDF/resources/redhat-config-network.rdf to /tmp/fetch6649
>   rdfRead /tmp/fetch6649: resource is not wellformed XML
>   Cannot install or locate resource redhat-config-network 
>   Do you want to search it in the catalog? [Y/n] : Y
>   Loading catalog to /tmp/fullIndex.rdf.gz
>   Fetching : http://rpmfind.net/linux/RDF/resources/fullIndex.rdf.gz to /tmp/fullIndex.rdf.gz
>   
>   Searching the RPM catalog for redhat-config-network ...
>   rdfRead /tmp/fullIndex.rdf.gz: resource is not wellformed XML
>   Cannot open catalog /tmp/fullIndex.rdf.gz
>   [root at localhost RPMS]# 
> 
>   Besides, I don't really want rpmfind to get packages on the net, I have
>   them on my disk.
> 
> 
> - I understand there is an apt-rpm, but I don't know if it will work right
>   with packages that ship with RH 7.3 (I'm not overly worried about getting
>   contrib packages from the web at this point).
>   If I should look into this, let me know.
> 
> My question is simple:
> How can I install  RH packages (not contrib) with the  dependencies in a way
> that actually works (and  I want to be able to say where  my packages are, I
> don't want to pull them from some random place on the net)
> 
> Thanks
> Marc
> -- 
> "A mouse is a device used to point at the xterm you want to type in" - A.S.R.
> Microsoft is to operating systems & security ....
>                                       .... what McDonalds is to gourmet cooking 
> Home page: http://marc.merlins.org/   |   Finger marc_f at merlins.org for PGP key

-- 
Rafael
The Gap Between the Rich and the Poor is Constant.



More information about the svlug mailing list