[svlug] Box frozen, then won't reboot.

Jean-Marc Libs libs at noos.fr
Sun Jul 14 16:34:02 PDT 2002


Hi,

I have my rather new computer which suddenly froze after 4 months of 
constant linux activity (non stop, of course). It did freeze once,
two days before, but this time I can't reboot it.
I can't even boot on a mandrake install disk or a linux BBC one.
Running memtest86 does display an unending stream of errors.
I'm usually not interested in hardware, so I wrote down what I did 
and maybe someone can advise me as to where my problem is.

I guess the HD is mostly OK (maybe some fsck required), and either
the Ram burned in the excessive heat, or the motherboard prevents
proper access to it. Or something else.

Trying to boot on a linux BBC on choice 1 (simple boot, no framebuffer)
displays the following:

----------------------
Partition check:
  hda: .... <everything OK here> ...
RAMDISK: Compressed image found at block 0
Unable to handle kernel paging request at virtual address 0b413bbc
current->tss.cr3 = 00101000, %cr3 = 00101000
*pde = 00000000
Oops: 0000
CPU:    0
EIP:    0010:[<801b8fe1>]
EFLAGS: 00010206
eax: 45893141   ebx: 8ffaaf20   ecx: 802ed93a   edx: 0000037d
esi: 8ffab388   edi: 8fca0823   ebp: 8ffaaedc   esp: 8ffaae6c
ds: 018    es: 0018   ss: 0018
Process swapper (pid: 1, process nr: 1, stackpage=8ffab000)
Stack: 0000013c 0000000b 00000007 0000005a 00000008 00000004 0000000b fffffff7
       0000037d 8fca0823 8ffab3e0 00000030 000000f6 8ffaaf20 00000900 00000012
       8ffaaf20 00000008 000000f8 00000009 8fca9008 8ffab388 00000009 0000000c
Call Trace: [<801b9cf5>] [<801b9cb5>] [<801b9ebe>] [<801b9f3c>] [<801b9f33>] [<801ba320>] [<80260000>]
       [<80123fc8>] [<8010ab74>] [<8010616c>] [<80106176>] [<8010967b>] [<80109684>]
Code: 8a 14 41 88 54 24 28 8b 9c 24 dc 05 00 00 0f b7 04 43 66 89
----------------------


Trying to boot on mandrake install disk gives slightly different result:

----------------------
Partition check:
  hda: .... <everything OK here> ...
RAMDISK: Compressed image found at block 0
kfree: Bad obj cff13000
Unable to handle kernel NULL pointer dereference at virtual address 00000
current->tss.cr3 = 00101000, %cr3 = 00101000
*pde = 00000000
Oops: 0002
CPU:    0
EIP:    0010:[<c011ea24>]
EFLAGS: ...
eax: ...
esi: ...
ds: ...
Process swapper (pid: 1, process nr: 1, stackpage=...
Stack: ...
Call Trace: ...
Code: ...
----------------------


I am trying to figure out what is wrong, here. I suppose the hard drive is OK.
I hope the only thing to change is the 256 Megs Ram.
Is there a chance that the motherboard is hosed ?

Thanks for any advice,
Jean-Marc Libs

-- 
"We are at a point where we could put all human knowledge onto the net. 
Yet legal regulation stops us. Why?" 
        -- Brewster Kahle




More information about the svlug mailing list