[svlug] E-Machines 667ir and Debian

Erik Steffl steffl at bigfoot.com
Fri Jan 18 00:44:02 PST 2002


Stephen Hill wrote:
> 
> I have heard many good things about the Debian distro, so I decided to
> replace the RH7.1 linux on my E-Machines.  I have tried several times
> to get the installation CD downloaded, usually timing out or some
> such, and I recently saw a 32Mb download that would get enough of
> Debian loaded that the rest could be taken down from the net.  That
> part succeeded.
> 
> However, now that I have rebooted, it doesn't seem to recognize my
> NIC.  I looked thru Google, and saw that the Network Everywhere Fast
> E'net Adaptor (NC100v2) NIC that E-Machines uses can be activated
> using the tulip.o driver, which IS on the drives as seen from linux.
> It's been an awfully long time since I played with putting in a NIC,
> but I first did an lsmod to see what modules were loaded (nothing at
> all) then tried to insmod tulip.o, which didn't work.
> 
> Am I thinking down the wrong path?  I figure that something ought to
> work, since I was able to get the rest of Debian downloaded via my LAN
> interface to the WAN, but I just can't seem to remember what the next
> step is to hook the os up with the driver.

  you might need to get the tulip driver from scyld.com (those are often
better), they even have fairly helpful mailing list (developers respond
quite often, at least that was the situation about year ago).

  in debian you want to put a file with module alias into /etc/modutils:

jojda:~>cat /etc/modutils/erik.eth 
# erik: this is a local file to take care of
#       modules for network card (from linksys webpage)

# not using tulip anymore (linksys LNE100TX)
# alias eth0            tulip

# rtl8139 driver from scyld, for d-link
# alias eth0            rtl8139

# rtl8139 driver from kernel (two cards)
alias eth0            8139too
alias eth1            8139too

# force 10 Mbs half duplex
# options tulip options=9

# EOF

  after you create a file similar to the one above (you can name it
anything you want, I just use erik.* for all my files, there are other
files in there installed by various packages) run:

  update-modules
  depmod -a
  modprobe tulip.o

  if it doesn't work you might need to compile your kernel to make it
work... remeber you have to compile driver with includes from kernel
(same version as the one you are currently running - use uname -a to
find ouy which version you run), not the ones from /usr/include/linux.

  use the following command to see which kernel sources are available:

dpkg -l kernel-source\*

  then install it (use the same version as uname -a prints):

apt-get install kernel-source-2.4.16

  it installs the tarball in /usr/src, untar it and use the include
files in there (gcc -I /usr/src/kernel-source-2.4.16/include ...) when
compiling module (if you get one from scyld.com)

	erik




More information about the svlug mailing list