[svlug] iptables problem with Red Hat 7.2

Craig Oda craigoda at yahoo.com
Thu Jan 10 00:26:02 PST 2002


I'm running a Red Hat 7.2 server as a firewall using iptables and have
a problem with the entry in /proc/sys/net/ipv4/ip_forward reverting
from 1 to 0 after about 10 minutes of use routing from my internal eth1
interface to eth0 external network.  I have tried this with 2 different
ethernet cards and have gotten the exact same results.  I've also tried
it with different 2.4 kernels.  I've tried it with a number of
different iptables rules and have turned off all dropped packet rules. 
So, the Linux box should be letting all packets through, which it does,
but only for about 10 minutes.  Then, it consistently changes the
ip_forward entry in the proc tables from 1 to 0.  How is this
happening?

I've applied all updates to Red Hat 7.2 and turned off any daemons that
appeared to me as not required.  I've also checked things like crontabs
to make sure that nothing is sweeping through the proc tables and
echoing something to the ip_forward file.  

I've also installed another version of Linux with a 2.2 kernel on a
different disk and the exact same hardware works fine with ipchains.  

I think the problem may be something with my iptables configuration,
but I'm baffled why the proc entry is changing automatically.

Has anyone seen something like this before?

 

__________________________________________________
Do You Yahoo!?
Send FREE video emails in Yahoo! Mail!
http://promo.yahoo.com/videomail/




More information about the svlug mailing list