[svlug] soundcard not detected (after moving of NIC)

Erik Steffl steffl at bigfoot.com
Thu Jan 3 01:02:02 PST 2002


  I get the error from alsa that soundcard is not detected, it worked
fine before I moved NIC to another PCI slot. I have ABIT VH6-II
motherboard.

  here's the HW side (1 isa slot, 4 pci slots altogether):

  ISA 1 soundblaster awe 64	irq 5
  PCI 1 voodoo 3		irq 9
  PCI 2 NIC RTL8139		irq 10 (or 11)
  PCI 3 NIC RTL8139		irq 11 (or 10)
  PCI 4 empty

  so it doesn't look like IRQ sharing problem, I checked BIOS boot
screen,
no conflicts with irq 5

  the soundcard DOES work in windows.

  the second NIC used to be in PCI slot 4 on irq 9 (shared with USB)

  dmesg soundcard related messages:

isapnp: Scanning for PnP cards...
isapnp: Calling quirk for 01:00
isapnp: SB audio device quirk - increasing port range
isapnp: Calling quirk for 01:02
isapnp: AWE32 quirk - adding two ports
isapnp: Card 'Creative SB AWE64 PnP'
isapnp: 1 Plug & Play card detected total

  (that's alsa isapnp that used to work before, I didn't change any
settings)

  syslog message when I run /etc/init.d. alsa start:

Jan  2 15:57:48 localhost kernel: ALSA card-sb16.c:606: Sound Blaster 16
soundcard not found or device busy
Jan  2 15:57:48 localhost kernel: ALSA card-sb16.c:608: In case, if you
have non-AWE card, try snd-card-sb16 module

jojda:/home/erik# cat /proc/interrupts 
           CPU0       
  0:    4265524          XT-PIC  timer
  1:          6          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  8:          1          XT-PIC  rtc
  9:          0          XT-PIC  usb-uhci, usb-uhci
 10:       2926          XT-PIC  eth1
 11:      18480          XT-PIC  eth0
 12:         26          XT-PIC  PS/2 Mouse
 14:     240251          XT-PIC  ide0
NMI:          0 
LOC:    4265306 
ERR:          0

  the card is recognized by isapnp (and by pnpdump) - do I need to fine
tune it? Since I have BIOS set to 'OS doesn't support PnP' I guess the
isapnp might try to set up the card and not succeed...

  any ideas? TIA!

	erik




More information about the svlug mailing list