[svlug] mount, smbfs, ssh, and local console weirdness

David Christensen dpchrist at inreach.com
Tue Aug 6 11:20:37 PDT 2002

svlug at lists.svlug.org:

"Rick Schultz" <bloodyvikings at sbcglobal.net> wrote:
> Here's a question: had you logged out of the console since adding your
> name to the smbuser group?  Reading the files and directories was
> allowed for anyone (judging from the directory listing), but writing
> required being a member of the group.
> I ran into a similar problem the other day: I added myself to a group,
> but the changes didn't seem to take effect immediately; I ended up
> logging out and back in, and then everything worked.

Thank you for your help.  :-)

I had a similar thought.  I do recall closing/ re-opening the shells on
my Gnome desktop and that the problem was still there.  (Those shells do
not appear to be login shells.)  I am reasonably sure I did not log out/
in.  I cannot recall if I did anything with the ssh shells on the
Windows box.

> Are changes to /etc/group supposed to take effect immediately?  If
> not, when is the file re-read?

Those are good questions.  The man page for "group" does not state when
the file is read.  The "group" man page refers to "login", but the only
reference to "/etc/group" is in the "/etc/usertty" section.
/etc/groups is a world-readable file, so the answer is likely to be
"/etc/group is read by the kernel and applications whenever the person
who wrote that particular stretch of code felt like it".  I suspect the
only way to find out would be to grep all source code for


More information about the svlug mailing list