[svlug] mount, smbfs, ssh, and local console weirdness

Rick Schultz bloodyvikings at sbcglobal.net
Tue Aug 6 10:32:23 PDT 2002

On Sun, 4 Aug 2002, David Christensen wrote:

> >From the console of r7320g, I can see directories and read their files.
> But, attempting to create a file:
>     dpchrist at r7320g:~$ touch /share/foo
>     touch: creating `/share/foo': Permission denied

Here's a question: had you logged out of the console since adding your
name to the smbuser group?  Reading the files and directories was allowed
for anyone (judging from the directory listing), but writing required
being a member of the group.

I ran into a similar problem the other day: I added myself to a group, but
the changes didn't seem to take effect immediately; I ended up logging out
and back in, and then everything worked.

Are changes to /etc/group supposed to take effect immediately?  If not,
when is the file re-read?

 Rick                This space intentionally          bloodyvikings@
 Schultz                   left blank                  sbcglobal.net

More information about the svlug mailing list