[svlug] half ethernet working

Vince Duperron duperron at charter.net
Wed Jul 25 20:12:01 PDT 2001


Hello;

Just installed debian over the net (Linux gate 2.2.19pre17-compact).
When I installed it asked if I wanted in install over 
ef0 or ef1.  After the installation was complete only ef0
is available.  Both network cards are identical PCI cards.
One works fine and one is invisible.

Any ideas about how to get the other network device available?

My goal with this system is a firewall, one side listens to 
my cable modem (using dhcp) and the other side connects
to my home network (serving dhcp).  So both devices would
be really handy!

Any help would be much appreciated.

Thanks 

Vince Duperron

PS. dmesg shows that I have both devices installed, but ifconfig 
shows that only one is available.

$ /sbin/ifconfig -av
eth0      Link encap:Ethernet  HWaddr 00:C0:F0:78:9D:BF  
          inet addr:192.168.200.253  Bcast:192.168.200.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:47285 errors:0 dropped:0 overruns:0 frame:0
          TX packets:28356 errors:0 dropped:0 overruns:0 carrier:0
          collisions:1 txqueuelen:100 
          Interrupt:10 Base address:0x6100 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:3924  Metric:1
          RX packets:15 errors:0 dropped:0 overruns:0 frame:0
          TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 

$ dmesg
Linux version 2.2.19pre17-compact (root at oink) (gcc version 2.7.2.3) #1 Mon Apr 2 01:35:19 PDT 2001
BIOS-provided physical RAM map:
 BIOS-e820: 0009fc00 @ 00000000 (usable)
 BIOS-e820: 00000400 @ 0009fc00 (usable)
 BIOS-e820: 01f00000 @ 00100000 (usable)
Detected 149693 kHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 298.18 BogoMIPS
Memory: 29780k/32768k available (1668k kernel code, 412k reserved, 756k data, 152k init)
Dentry hash table entries: 4096 (order 3, 32k)
Buffer cache hash table entries: 32768 (order 5, 128k)
Page cache hash table entries: 8192 (order 3, 32k)
CPU: Intel Pentium 75 - 200 stepping 0c
Checking 386/387 coupling... OK, FPU using exception 16 error reporting.
Checking 'hlt' instruction... OK.
Checking for popad bug... OK.
Intel Pentium with F0 0F bug - workaround enabled.
POSIX conformance testing by UNIFIX
PCI: PCI BIOS revision 2.10 entry at 0xfb300
PCI: Using configuration type 1
PCI: Probing PCI hardware
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
TCP: Hash tables configured (ehash 32768 bhash 32768)
Starting kswapd v 1.5 
vga16fb: initializing
vga16fb: mapped to 0xc00a0000
Console: switching to colour frame buffer device 80x30
fb0: VGA16 VGA frame buffer device
Detected PS/2 Mouse Port.
Serial driver version 4.27 with no serial options enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
pty: 256 Unix98 ptys configured
RAM disk driver initialized:  16 RAM disks of 4096K size
loop: registered device at major 7
PIIX3: IDE controller on PCI bus 00 dev 39
PIIX3: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:pio, hdb:pio
    ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:pio, hdd:pio
hda: SAMSUNG WA32162A, ATA DISK drive
hdd: FX600S, ATAPI CDROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: SAMSUNG WA32162A, 2060MB w/128kB Cache, CHS=523/128/63
hdd: ATAPI 6X CD-ROM drive, 256kB Cache
Uniform CD-ROM driver Revision: 3.11
Floppy drive(s): fd0 is 1.44M, fd1 is 1.2M
FDC 0 is a post-1991 82077
md driver 0.36.6 MAX_MD_DEV=4, MAX_REAL=8
sim710: No NCR53C710 adapter found.
scsi: <fdomain> Detection failed (no card)
NCR53c406a: no available ports found
sym53c416.c: Version 1.0.0
Failed initialization of WD-7000 SCSI card!
DC390: 0 adapters found
scsi : 0 hosts.
scsi : detected total.
3c59x.c 18Feb01 Donald Becker and others http://www.scyld.com/network/vortex.html
pcnet32.c: PCI bios is present, checking for devices...
tulip.c:v0.91g-ppc 7/16/99 becker at cesdis.gsfc.nasa.gov
eth0: Lite-On PNIC-II rev 37 at 0x6100, 00:C0:F0:78:9D:BF, IRQ 10.
eth1: Lite-On PNIC-II rev 37 at 0x6200, 00:C0:F0:76:49:9A, IRQ 9.
via-rhine.c:v1.08b-LK1.0.0 12/14/2000  Written by Donald Becker
  http://www.scyld.com/network/via-rhine.html
Partition check:
 hda:hda: status error: status=0x59 { DriveReady SeekComplete DataRequest Error }
hda: status error: error=0x04 { DriveStatusError }
hda: drive not ready for command
hda: status timeout: status=0xd0 { Busy }
hda: drive not ready for command
ide0: reset: success
 hda1 hda2 hda3
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 152k freed
Adding Swap: 141112k swap-space (priority -1)
Linux PCMCIA Card Services 3.1.22
  kernel build: 2.2.19pre17-compact unknown
  options:  [pci] [cardbus]
Intel PCIC probe: not found.
ds: no socket drivers loaded!





More information about the svlug mailing list