[svlug] Corrupt File?

Dave Zarzycki dave at loki.sbay.org
Wed Apr 28 23:11:43 PDT 1999


On Wed, 28 Apr 1999, John Mark Walker wrote:

> I feel a little stupid for bringing this up, but I have a file that I simply
> cannot get rid of.  ls -l produces:
> 
> (snip)
> b--sr-sr--   1 28265    26988     32,  58 Apr  2  1987 krn.mo
> (snip)
> 
> First of all, what does "b" stand for?  

A "block" device.

In this case, with major number 32 and minor number 58.

The modification date is interesting: 1987. That predates Linux...

The owner of the file is somebody with the UID equal to 28265.
The GID (group ID) is 26988. Try looking at /etc/passwd and /etc/group to
see if these IDs make any sense. (Did you ever assign them at one point?)

This is truly weird.

Have you tried removing it as root?

> I tried fscking the partition, but it is reported as clean - after it found a
> couple of other errors.  I can't simply delete the file either because
> permission is always denied.

What is the permissions on the above directory?

Is the immutable flag set?

"lsattr krn.mo" should answer that question.

In any case, your file system is probably of questionable condition,
regardless of which Unix you are running.

davez


--
echo "unsubscribe svlug" | mail majordomo at svlug.org
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ to unsubscribe
see http://www.svlug.org/mdstuff/lists.shtml for posting guidelines.



More information about the svlug mailing list