[Smaug] (forw) Could you fix the Smaug-Web script?

Rick Moen rick at linuxmafia.com
Thu Sep 16 19:42:59 PDT 2004


Oh, by the way, I now get a DSN saying "unroutable address" on any mail
to dgatwood at dgatwood.net.  FYI.

----- Forwarded message from rick -----

Date: Thu, 16 Sep 2004 19:37:20 -0700
To: dgatwood at dgatwood.net
Subject: Could you fix the Smaug-Web script?

David, something really odd is going on with check-ins to Smaug-web.
Can you help?

First, I tried going to my standard checkout directory of
/var/www/smaug/htdocs and doing "cvs update".  I got authentication 
errors:  It seemed as if the SSH keys on the SourceForge server end had
changed.  (I removed the cached keys from my ~/.ssh directory, and tried
again.)  Then, I got some other bizarre errors, which unfortunately I 
didn't make a record of.

Rather than try to debug everything, I moved my /var/www/smaug/htdocs
directory (containing my old checkout) out of the way, created a fresh
/var/www/smaug/ stub, and did an absolutely fresh checkout, like:

$ export CVS_RSH=/usr/bin/ssh
$ cvs -z3 -d:ext:rickmoen at cvs.sourceforge.net:/cvsroot/smaug-web co htdocs

...which finally got me a checkout.  I made edits to *.sub, newsleft.html,
and dir.html, and created new file map-smaug-tinys.jpeg .  Did:

$ cvs add map-smaug-tinys.jpeg
$ cvs ci *.sub newsleft.html
$ cvs commit

Later, I verified that my checkins had actually made it into the CVS
repository by doing a fresh check-out.  They're definitely in the
repository.

You can see my local checkout files on _my_ system at
ftp://linuxmafia.com/smaug/htdocs/ .


ANYHOW, the script /home/groups/s/sm/smaug-web/web_update on
shells.sourceforge.net doesn't seem to be doing anything useful,
anymore.  (I don't think I can run it fruitfully with my user
authority.)  Do you have time to look into it?

I'm sorry I don't have time to chase it down, but I'm a bit swamped.

My fallback option would be to modify the htdocs directory in
/home/groups/s/sm/smaug-web/ directly, which obviously should be avoided
if necessary.  (If you notice that the mtime on web_update has changed,
it's because I tried editing hostname "cvs1" in the script to "cvs".
That didn't seem to help, so I backed out the change.)

Thank you!

----- End forwarded message -----



More information about the Smaug mailing list