[Smaug] scruz.org cvs question

Rick Moen rick at linuxmafia.com
Tue, 7 May 2002 11:51:29 -0700


Quoting Karsten Wade (phig@phig.org):

> I just tried it again - my local copy of meeting.sub is changed, tried to
> check-in, and got the below error.
> 
>   [kwade@thalia smaug]$ cvs -z3
>   -d:ext:quaid@cvs.smaug-web.sourceforge.net:/cvsroot/smaug-web ci htdocs
>   cvs commit: Examining htdocs
>   cvs commit: Examining htdocs/backup
>   cvs commit: Examining htdocs/host
>   cvs commit: Examining htdocs/jacob
>   cvs commit: Examining htdocs/rightbar
>   cvs commit: Examining htdocs/test
>   quaid@cvs.smaug-web.sourceforge.net's password: 
>   Could not chdir to home directory /home/users/q/qu/quaid: No such file
> or directory
>   cvs server: Up-to-date check failed for `htdocs/index.sub'
>   cvs [server aborted]: correct above errors first!
>   cvs commit: saving log message in /tmp/cvsgUsyt1

Do "cvs update" to refresh.  Then, locally in your checked-out tree, cd
into htdocs.  Make the changes to meeting.sub (as you did).  Then do:

   cvs ci

This assumes that you have CVSROOT set appropriately, or set in your 
CVS/Root file, or such.

The /home/users/q/qu/quaid error isn't releveant.  Not sure why you're
getting it, but it obviously isn't stopping you from doing anything,
as witness your experience with index.sub, earlier.

The "Up-to-date check failed" error is your culprit.  No, I don't know
why you're getting it, but it's definitely what's tripping you up.

Ah, here:

http://www.loria.fr/~molli/fom-serve/cache/127.html

Remember I said you needed to do "cvs update" just before starting your
edit?  Now, you know why.